Overview
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Email Parser (AEP) is software designed for processing incoming E-mail messages. AEP can be used to perform the following jobs automatically:

·save time and money by automating email processing

·processing of orders or other forms received via E-mail

·sending replies to clients

·filling databases with data extracted from e-mail, supports Access, SQL Server, MySQL, and many other database types. Also Microsoft Excel Spreadsheets.

·sorting and redirecting e-mail message flows. You can also forward the original email on to multiple recipients. You can control who you send new emails to, based on the content of the incoming email

·compiling mailing lists, maintaining statistics of any kind

·creating automatic answering services, mail robots, watchdogs

·saving back-up copies of important messages

·monitoring web page changes

Advanced Email Parser can be integrated with various software products that support ActiveX technology. This allows data processing in external modules from different developers. For such integration, scripting languages based on Microsoft Active Scripting technology - JScript and VBScript - are used.

AEP features user-friendly graphic interface. Step-by-Step debugger, Debug messages and detailed log make configuring the program easier.

Advanced Email Parser is an effective and reliable message processing tool, with high traffic capacity and little time required for each message processing.

© 2020 Mediatwins s.r.o. All rights reserved.


Working with the Program
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

How does AEP work?

AEP downloads messages from mail servers and processes them using a list of rules set up by the user. Rules consist of filters and processing components.

When downloading a message, AEP checks whether it is to be processed or not using filters. If the message is to be processed, AEP adds it to the processing queue. Upon completion of a working session with a mail server, AEP processes all the messages in the queue.

Processing components are used to parse, modify, and store data from messages. To exchange data between components, variables are used.

AEP allows:

·parsing data line by line, block by block, using regular expressions

·modifying data using templates

·storing data into files or databases

·sending data via e-mail

·processing data with scripting languages

·transferring data to external programs

The rules and processing components are used in the order of their listing. To check whether a rule works correctly or not, debug messages are used. Debug messages can be created through loading from a file or by catching an incoming message.

Rules are debugged in the Constructor window.

Mail servers are accessed using mail accounts. Accounts store the parameters of the server connection and the connection schedule.

Collector Mode

When working with an account in the Collector Mode, AEP establishes a connection with a mail server itself. Depending on the account settings, AEP can either delete processed messages on the server or not. In any case, a message will be processed by AEP only once.

Accounts are configured in the Accounts Window.

All the events that take place during program operation are registered in the Log. The Log can be viewed in the Log Viewer.

See also

Accounts Window

Constructor Window

Rule Components


Main Window
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Main MenuGlobal Variables PanelComponents PanelAccounts WindowConstructor Window


Main
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

From the Main Menu you can quickly access the AEP functions.

Program settings

Change settings of AEP.

User options

GUI and prompts options

Show log

Call the Log Viewer

Clear log

Clear log manually.

Capture One Message

Capture one incoming Debug Message

Capture All Messages

Capture All incoming Debug Message

Import Rules

Import rules into Constructor Window. Supported formats of rules: v.1 (ANSI text - .txt), v.2 (Unicode text - .rule) and v.3 (Compressed XML - .rulex)

Export All Rules

Export All rules to file. Typically for backup or exchange with other AEP installation. If you want export only one rule use context menu in Constructor Window

Load Examples

Open folder with Example Rules. Help to learn how to work with AEP components

Import Accounts

Import accounts exported from AEP. Supported formats of accounts file: v2 (Unicode text - .account) or v3 (Compressed XML - .accountx)

Export Accounts

Export all accounts to file. Typically for backup or exchange with other AEP installation. If you want export only one account use context menu in Accounts Window

Menu Command | Description
Save configuration | save changes
Backup configuration | backup Rules, Accounts, Settings, Global Variables and User Options into archive
Restore configuration | restore Rules, Accounts, Settings, Global Variables and User Options from backup archive
Exit | quitting the program


Log Settings
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

On this tab, you can set the Log operation properties.

Cleanup logs at startup

Enables automatic log cleaning upon AEP launch. If the box is unchecked, the log will be cleaned later.

Cleanup logs at shutdown

Enables automatic log cleaning upon AEP shutdown. If the box is unchecked, the log will be cleaned later.

By size

Log size in megabytes, at which it will be cleaned

Rotate logs (Max stored archives)

Enable log rotation. Count of old log archive that stored in the log folder.

Cleaning frequency

Possible values: Daily at specified time, Eventually

Store log file in

Path where AEP store log file.

Compress log before clean

AEP compress file before rotate. This option save disk space.

Store compressed files in

Compressed files will be stored at different location then log file

Maximum stored archives

Maximum archives stored for history. After rotation the oldest archive is removed.


Advanced Settings
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

In this tab you can define additional program settings.

Queue Processing Priority

Rule over queue priority. If you want to process messages queue slower, move the slider closer to "Short". If you want to process messages queue faster, move the slider towards "Long". It will increase CPU usage, so please be careful.

International Settings

Specifies default encoding for incoming messages.

Default Encoding

Set the character set standard will be used for default encoding.

Use default encoding for all incoming messages

Displays all incoming messages using the default encoding regardless of the message headers. Select only if your messages are frequently unreadable because the language specified in their headers is inconsistent with the message bodies.


General
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

In this tab you can define GUI behavior and save policy.

Auto save configuration on exit

Enables automatic saving of configuration changes before exit.

Auto expand tree on drag item over

Enables automatic expanding rules tree in Constructor window on dragging items.

Use large Toolbars in Docking Panes

Enlarge icons in toolbars

Clear windows size and position

Resetting saved sizes and positions of all AEP dialogs and windows.


Delete Prompts
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

In this tab you can define what prompts will be displayed with delete operation.

No prompt to delete Account

Not display confirmation prompt while trying to delete the account.

No prompt to delete Rule

Not display confirmation prompt while trying to delete the rule.

No prompt to delete Component

Not display confirmation prompt while trying to delete the component.

No prompt to delete the Component Holder

Not display confirmation prompt while trying to delete the component holder.

No prompt to delete Variable

Not display confirmation prompt while trying to delete the global variable.

No prompt to delete Datasource

Not display confirmation prompt while trying to delete the datasource.

No prompt to delete Debug Message

Not display confirmation prompt while trying to delete the debug message.

No prompt to Clear log

Not display confirmation prompt while trying to clear AEP log.


Service Components Control
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

SMTP Server

Advanced Email Parser can work as an e-mail SMTP server. The built-in mail server supplied with AEP is capable of performing all operations involved in receiving of mail messages.

Usage of an internal mail server delivers a number of benefits. For example, with it there is no need to query all mailboxes every 5 seconds to ensure timely reception of urgent, high-priority mail. Instead you can send e-mails to the AEP built-in SMTP server. This would allow release of POP3 servers from excessive load, and avoids overgrowth of AEP log files. When processing messages, SMTP Server is convenient to use together with the Message Sender component for further forwarding of the messages.

Before you start using the built-in mail server you have to set its settings.

Accounts Schedulers

Start/Stop schedulers of all accounts.


SMTP Server Settings
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Domain Name

E-mail addresses with this domain will be considered local.

Server Name

The name of the mail server account. Based on this name, messages received from the internal mail server can be detected using the Account Filter in processing rules.

Allow Connection From

The list of network addresses access to the server is allowed from. All the allowed groups of network IP addresses are to be separated by a comma, use of address wildcards is possible.

Listen on Address

The mail server will receive queries from the selected network interface.

Listen on Port

Number of the port queries to which the mail server will come.

Timeout

Timeout of waiting client command.

Enable at startup

Check this box to allow run the internal mail server when AEP start.

Process All Incoming Messages

Check this box if you want the server to process all incoming messages. Otherwise, messages belonging to a domain other than specified in the Domain Name field won't be received.

Detailed Log

Check this box if you want the SMTP server to write detailed information about the actions it performs to the log file.

Remarks

The internal SMTP server doesn't receive any messages while a processing session is in progress. Message sending from processing components (e.g., SMTP Sender or Message Sender), scripts, or external applications is not possible.

See also

SMTP Sender

Message Sender

SMS Sender


License and Support

Advanced Email Parser website

Navigation: Working with the Program > Main Window > Main Menu:

Licence and Support
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Home Page

Open the Home Page of AEP on the program website

Support

Open the Technical Support section on the program website

Quick Tour

Open the brief overview and examples of AEP on the program website

Check for Updates

Manual check for the new version of AEP.

Auto Update options

Settings of Auto Updater

Manage License

Open the License Manager Wizard. It helps Activate or Deactivate purchased license.

Renew License

If your license near to expired you can start a renew process from the application.

Buy Now!

Open Ordering page on the program website.


License Info

Advanced Email Parser website

Navigation: Working with the Program > Main Window > Main Menu:

Licence Info
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Show detailed information about purchased license and program version. This information is useful if you want to contact the Technical Support Team.

System Info

Call MS System Info application. Helps to collect information about your computer. Technical Support Team may request this information.

Remark

All information collected by MS System Info DOES NOT contain any private or personal information. Only parameters of Operating System and hardware components.


Constructor Window
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Use the Constructor window to edit the list of Rules.

To create a rule component, drag the desired component with the mouse from the Components panel to the Constructor window.

The following actions are possible in the Rules Window for Rules and Components

Icon | Hot key | Description
iconcut | Ctrl-X | cut a Rule/Component to the clipboard
iconcopy | Ctrl-C | copy a Rule/Component to the clipboard
iconpaste | Ctrl-V | paste a Rule/Component from the clipboard
iconnew | Ctrl-N | add new Rule
icondel | Del | delete a Rule/Component
iconedit | F2 | rename Rule/Component name
iconfind | F3 | search text in Components
iconprop | Alt-Enter | open Rule/Component properties window
iconup | Alt-Up | move a Rule/Component up
icondown | Alt-Down | move a Rule/Component down
 | Alt-D | disable Rule/Component
 | Alt-R | set Rule read-only (see Rule Properties)
 | Alt-T | set Rule realtime (see Rule Properties)
 | Alt-N | set Rule Continue flag (see Rule Properties)
 | Alt-C | set Component Critical flag
 | Alt-B | toggle Breakpoint (see Rules Debugging)

See also

Accounts Window

Log Window

Filters

Processing Components


Rule Properties
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Use this window to set general properties of the Rule.

Message Mark

Set the string to be added to a message subject upon processing. If the same string is set for several Rules, it will be added only once.

Process Only Message Header

Enables message processing mode to parse message header only. This mode allows a speed increase in processing of large messages, when only header data is need to parse.

Realtime Processing

Enables a mode when message processing begins immediately upon message receipt. The message which is being processed, will NOT be placed into the processing queue.

Continue With the Next Rule

Enables continuing message processing with the next rule.

Disabled

Exclude rule from processing.

Read-only

Disable modification rule components.

Ignore capture message action

Capture message flag does not affected on this rule

Comments

User comments or description for this rule.

See also

Constructor Window


Accounts Panel
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Right click to create a new mail account. In this window, you can control the accounts list. In addition, you can see processed message statistics and the date of last connection to a mail server.

The following actions are possible with the accounts list

Icon | Hot key | Description
iconAccountCheck | Alt+C |
iconAccountCheckAll | Alt+A |
iconAccountAdd |  | add new account
iconAccountDelete | Del | delete selected account
iconAccountProperties | Alt+Enter | open account properties window
iconAccountClearHistory |  | clear history of the previously processed messages
iconAccountExport |  | export selected account
iconAccountAsCurrentUser |  | process account under the current user credentials (for MAPI account only)
iconAccountAsUser |  | process account under another user credentials (for MAPI account only)
 | Space | enable/disable the account

Accounts with the following types are possible to create

Type | Description
POP3 Account | used to receive e-mail messages from POP3 servers.
IMAP Account | used to receive e-mail messages from IMAP servers.
MAPI Message Storage Account | used to process messages from mail programs supporting MAPI.
RFC822 Compatible Account | used to process messages saved in files. Message format should be compatible with RFC822 or RFC2822.
Unix Compatible Mailbox File Account | used to process messages saved in Unix mailbox file.
Scheduled Message Account | used to initiate processing by predefined message


POP3 Account
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

An account of this type is used to receive e-mail messages from POP3 servers.


General Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Account Name

Set account name.

Process Only New Messages

Enable/disable new messages processing only.

Remove Messages From Server

Enable/disable deletion of messages on server when working in the Collector Mode.

Detailed Debug Log

Enable/disable debug info recording during incoming mail processing.

Write Message to Log

Enable/disable write the processed message to the log file. Beware to use this option in production. This option can heavily grow the log file and used only for debugging or problem-solving.

Log Protocol

Log connection protocol with remote server.

See also

POP3 Account


Server Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Server address

The address of your POP3 server where the account's mailbox is located.

Login Name

The POP3 user name for access to your mailbox on the server.

Password

The password for logging onto the POP3 server.

Port

Set mail server port number. For POP3, this number usually is 110 or 995 for TLS connection.

Security

Regular - Standard POP3 plain text communication protocol

Secure to regular port (STARTTLS) - STARTTLS is an extension to plain text communication protocols, which offers a way to upgrade a plain text connection to an encrypted (TLS) connection instead of using a separate port for encrypted communication.

Secure to dedicated port (TLS) - Encrypted communication for POP3 to the server using Transport Layer Security (TLS).

Timeout in sec.

Set the waiting time for a mail server response. When this time is over, your computer stops attempting to receive mail.

Test Login

Checks the settings attempting to connect to the server.

See also

POP3 Account


IMAP Account
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Account of this type is used to download messages from the mail server via IMAP v4 protocol.


General Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Account Name

Sets account name.

Process Only New Messages

Enables/disables processing of new messages only.

Process Only Unread Messages

Enables/disables processing of unread messages only.

Process Only Flagged Messages

Enables/disables processing of flagged messages only.

Process Only Answered Messages

Enables/disables processing of answered messages only.

Mark Messages As Read

Set flag 'Read' for processed message in the mailbox.

Remove Messages From Server

Enables/disables removal of messages from server when working in the Collector mode.

Detailed Debug Log

Enables/disables recording of debug information while processing incoming messages.

Write Message to Log

Enable/disable write the processed message to the log file. Beware to use this option in production. This option can heavily grow the log file and used only for debugging or problem-solving.

Log Protocol

Log connection protocol with remote server.

See also

IMAP Account


Server Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Server Address

Sets the IMAP4 server address.

Login Name

Sets the login used to access mail server.

Password

Sets the password used to access mail server.

Port

Set mail server port number. For IMAP4, this number usually is 143 or 993 for TLS connection.

Security

Regular - Standard IMAP4 plain text communication protocol.

Secure to regular port (STARTTLS) - STARTTLS is an extension to plain text communication protocols, which offers a way to upgrade a plain text connection to an encrypted (TLS) connection instead of using a separate port for encrypted communication.

Secure to dedicated port (TLS) - Encrypted communication for IMAP4 to the server using Transport Layer Security (TLS).

Timeout in sec.

Set the waiting time for a mail server response. When this time is over, your computer stops attempting to receive mail.

Test Login

Checks the settings by attempting to connect to the server.

Folder

Choose the folder for processing. Multiple folders selection is allowed.

Name of the folder from which messages are to be processed. If not choose, INBOX folder will be processed in the Collector mode. To work in the Broker mode, a folder name must be specified. The list of folders is received from the IMAP4 server, so it is important that correct settings on the Server Tab are entered.

See also

IMAP Account


MAPI Message Store Account
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

This account is used to process messages from mail programs supporting MAPI (MS Outlook, MS Exchange).

Important

Due Operating System limitation 64 bit version of AEP does not work with 32 bit version of MAPI and vice versa.


General Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Account Name

Set account name.

Process Only New Messages

Enable/disable new messages processing only.

Process Only Unread Messages

Enable/disable unread messages processing only.

Include Attachments

Enable/disable attachments inclusion into messages.

Mark Messages As Read

Set flag 'Read' for processed message in the mailbox.

Remove Messages From Server

Enables/disables removal of messages from server when working in the Collector mode.

Detailed Debug Log

Enable/disable debug info recording during messages processing.

Write Message to Log

Enable/disable write the processed message to the log file. Beware to use this option in production. This option can heavily grow the log file and used only for debugging or problem-solving.

Log Protocol

Log connection protocol.

See also

MAPI Message Store Account


MAPI Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

32-bit Client

MAPI Client is a 32-bit application. For example, 32-bit Outlook installed on 64-bit Windows

Mail Client

Set the mail client which serves messages storage.

Profile Name

Set name of MAPI profile.

Profile Password

Set password used to connect to MAPI profile (if exist).

Test Login

Test connection using entered settings.

Storage

Set MAPI storage which contains messages for processing.

Folder

Choose the folder for processing. Multiple folders selection is allowed.

Ignore Storage Cache

Use remote storage instead of local copy. One of the scenarios for Outlook - MS Exchange

Not use MAPI Transport Headers property

Do not use MAPI PR_TRANSPORT_MESSAGE_HEADERS property. This property contain headers that contain message received via SMTP servers. Can be stripped or removed by MS Exchange Server or MS Outlook.

Use this option only if you know how MAPI works

Not use Microsoft MAPI to MIME Converter

Do not use method of MAPI interface MAPIToMIMEStm, instead use own conversion function to assemble message by RFC 2822. Some versions of Outlook have problem with this MAPI function.

See also

MAPI Message Store Account


Sorting Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Enable messages sorting

Allow AEP to sort messages before download for processing

First sort/Second sort/Third sort

Sort messages by: Sender Name, Sender Email, Recipient Name, Recipient Email, Subject, Size, Delivery Date, Creation Date, Submit Date, Last Modification Time

Sorting direction: Ascending, Descending


RFC822 Compatible Account
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

This account is used to process messages saved in files. Message format should be compatible with RFC 822 or RFC 2822.


General Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Account Name

Set account name.

Process Only New Messages

Enable/disable new message file processing only.

Remove Messages After Processing

Enable/disable deletion of processed messages into the message directory.

Detailed Debug Log

Enable/disable recording of debug info during messages processing.

Write Message to Log

Enable/disable write the processed message to the log file. Beware to use this option in production. This option can heavily grow the log file and used only for debugging or problem-solving.

See also

RFC822 Compliant Account


Files Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Messages Folder

Set directory which contains message files.

Messages Mask

Enables message files mask usage. By default all files in the directory will be processed.

Custom Lock File

Enables lock file usage. If file name does not contain folder name, then lock file will be opened in message files directory.

See also

RFC822 Compatible Account


Advanced Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Additional Lock Files

Set list of additional lock files. If the name of lock file doesn't contain a path then the file will be opened in the message files directory.

See also

RFC822 Compliant Account


Unix Compatible Mailbox File Account
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

This account is used to process messages stored in text file formatted as Unix mailbox.


General Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

This tab contains general properties of an account. It allows editing of account name and message processing parameters.

Account Name

Set account name.

Process Only New Messages

Enable/disable new message processing only.

Remove Messages After Processing

Enable/disable deletion of messages.

Detailed Debug Log

Enable/disable write the processed message to the log file. Beware to use this option in production. This option can heavily grow the log file and used only for debugging or problem-solving.

See also

Unix Compatible Mailbox File Account


Files Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Allows setting of mailbox file and name of lock file used for synchronizing of working with other applications which are using mailbox file.

Mailbox File

Set file name of mailbox.

Custom Lock File

Enables lock file usage. If file name does not contain path, then lock file will be opened in the directory of mailbox file.

See also

Unix Compatible Mailbox File Account


Advanced Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

This tab contains a list of additional lock files.

Additional Lock Files

Set list of additional lock files. If the name of the lock file doesn't contain a path then the file will be opened in the message files directory.

See also

Unix Compatible Mailbox File Account


Scheduled Message Account
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

This account is used to initiate process by predefined message (as trigger).


General Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Account Name

Set account name.

Detailed Log

Enable/disable debug info recording during message processing.

See also

Scheduled Message Account


Message Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders


Processing Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

On this tab you can control the order of receiving messages and their further processing.

Reconnect Every

Enables the mode with which a new connection with mail server is established after the specified number of messages is received or in a certain time interval. Use the sliders to set desired number of messages and time.

Wait for Processing Queue

Enables processing of received messages prior to reconnection.


Scheduler Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

This tab contains the scheduler properties. Scheduler is used to check for new messages on a mail server automatically. You can set specific time and interval of connecting to mail server.

Enable scheduler

Check this option to enable scheduler for this account

Mode

Set period when account has been checked.

Available periods: Minutes, Hours, Days, Weeks, Months, at Specified Date or at Startup


Statistics Page
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Detailed statistics and information about scheduled terms of the account.

Update

Manual re-read collected statistics of the account

Clear

Clears collected statistics. Can't be undone.


Data Sources Panel
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Designed to manage data sources for multiple components at once when working with databases.

Once any changes are made to Data Source parameters of any component, it will automatically apply those changes to all other components with Data Source of the same name. Data Source Panel allows renaming Data Source, deletion or replacing it.

Icon | Command | Description
iconDataSourceAdd | Ins | Add new Data Source
iconDataSourceDuplicate | Ctrl+D | Duplicate selected Data Source
iconDataSourceDelete | Del | Delete orphaned Data Source. I.e. Data Source than not used with any component
iconDataSourceRename | F2 | Rename selected Data Source
iconDataSourceReplace | Ctrl+R | Replace selected Data Source with another
iconDataSourceProperties | Alt+Enter | Data Source properties
iconDataSourceFind | Ctrl+F | Find component associated with selected Data Source
 | DSN String | DSN connection string used in ODBC connectivity process
 | Used | How many components use this Data Source


Debug Window Panel
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Debug Panel allows you to control the debugging process.

Icon | Command | Description
iconrun | F5 | Run execution until end processing or next Break-point
iconstep | F10 | Step Next. Execute component and pause
iconstop | Ctrl+F10 | Stop debug execution
 | Step-by-Step Debug | Enable step-by-step execution. If disabled, execution will be paused only on Component with Breakpoint flag
 | Enable Breakpoints | Allow use Breakpoints. If disabled, execution will not stop on Components with Break-point flag


Immediate Variables Panel
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Show values of Rule Variables during execution of Debug Message.


Components Panel
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The Components panel shows all the Rule Components provided by AEP. For user's convenience, the Components are sorted in Component panel folders based on their type.


Debug Messages Panel
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Contains all Debug Messages. You can organize and group messages using drag-n-drop. You can add new Debug message, delete, rename and export existing messages by pressing buttons in the toolbar.


Variables Panel
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Variables Panel shows variables defined by components in the selected Rule. You can organize variables into groups with drag-n-drop.

Double-click on the variable name select the Component in the Rule that define this Variable


Global Variables Panel
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Global variables can be accessed by any processing component from any rule, and they also can be used for data exchange between components and rules. Each global variable has its own effective interval. A variable is initialized by the initial value at the beginning of the effective interval. Within the effective interval, any processing component from any rule can read and change its current value.

The global variable list is a table with the following columns:

Type - Global variable type depending on the effective interval.

Name - Global variable name which appears in the general variable list. By default, the name appears in the Variables group.

Current - Current value of the global variable.

Default - Initial values of the global variable, bound to it on initialization at the beginning of each effective interval.

Comment - Text comment.

Managing the global variable list

To create a new global variable, click the iconnew button. Set desired parameters in the property grid. In that panel you can also specify the variable position in the list or change type of variable. To do that, just use mouse to drag and drop variable to desired position.

To delete a global variable, click icondel.

Global variable types

There are 4 global variable types depending on the effective interval.

Type | Effective interval | Initialization | Typical applications
Message | Current message processing | Before processing a message with the first rule | Data transfer between the rule
Session | Current message receiving sessions | Before processing the first message in the current session with the first rule | Collecting statistics, intermediate results while receiving messages
Program | Current AEP launch | On AEP startup | Storage of the most common parameters, statistics
Permanent | Permanently stored in the Registry, max length 16384 bytes | On variable creation or on change of Default Value parameter | Storage of parameters necessary after relaunch of the program.

See also

Variables


Log Viewer
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

In the Log Viewer you can see what events have taken place during the program operation. When messages are being processed, results of all the successful actions or failures are recorded in the Log. This information also can be used for rules debugging. Rows with debug icon can be opened by double click to view additional information. For other rows information shows in the 'Details' pane.

Information in the Log is stored for a certain number of days and then will be deleted. The number of days is set on the Log Properties.

Icon | Description
iconLogOpen | Open existing log
iconLogSave | Export log. You can save as uncompressed file, or compressed with 7z or zip algorithm
iconLogUpdate | Refresh log
Refresh interval | Refreshing interval in seconds

See also

Rules Debugging


Message Analyzer
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can view debug messages with Message Analyzer. This tool helps you to determine parts and encoding of messages for correct parse.

Raw Data

Parts of the message according to RFC 2822 (Internet Message Format). Parts of the message can be encoded and contains different code pages.

Decoded Data

Data converted and decoded by AEP for ease of processing. These parts are available for components as Source and provide information in a human-readable form.


Rule Components
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

With the Rule components, you can set what messages are to be processed by the Rule, and to choose processing method.

There are the following Rule components in AEP

Filters | Used to check whether a message is to be processed or not.
Processing components | Used to parse, modify, and store data from messages.

To disable a rule or a rule component, check on the Disabled box in its context menu or press Alt+D.


Filters
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Filters are rule components used to check whether a message is to be processed with the rule or not. Filters are used one by one in the order of their listing. If a message fails to come through any filter, it is not processed. Only data from a message header are used for filtering, to avoid downloading an entire message before it is clear whether it is to be processed or not.

The are the following filters in AEP:

Message Filter | Checks if the string is present in a message part.
Size Filter | Used to filter messages by size.
Account Filter | Used to filter messages downloaded with the specified account.
Filter Group | Used to combine work results of some filters and filter groups using logical operation.

For the messages received with accounts operating in the Collector mode, the time of checking a message with all filters from the Rules list should not exceed mail server timeout.

The filters are placed in the Filters folder in the Components panel.


Message Filter
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to check if the string is contained in a specified message part.

Note to users of previous versions

This filter combines the capabilities of the following filters in previous versions of AEP: Subject Filter, Sender Name Filter, Sender Email Filter, Recipient Name Filter, Recipient Email Filter, Header Filed Filter.
These filters are converted into the Message Filter, if you are upgrading your old configuration or import rules from previous versions of the program.

Source

Message part in where AEP search the sting. Available parts:
Subject, Sender Email, Sender Name, Recipient Name, Recipient Email, Header filed and Custom Variable.

Header filed can be any of message headers. For example X-Forwarded-For. Value is a case-insensitive.

Custom Variable - any of variables from Global Variables list

Condition if Source

Empty - TRUE, if the text source is empty.

Equals String - TRUE, if the text source is the same as any string specified in the dictionary.

Contains String - TRUE, if the text source contains any string specified in the dictionary.

Begin With String - TRUE, if the text source begins with any string specified in the dictionary.

End With String - TRUE, if the text source ends with any string specified in the dictionary.

Contains All Words From String - TRUE, if the text source contains all words from any string specified in the dictionary.

Contains Any Word From String - TRUE, if the text source contains any word from any string specified in the dictionary.

Search Options

Whole String

Message part is checked for being completely the same as the filter string.

Match Case

Case-sensitive string comparison.

Use Wildcards

Search string contains wildcards. Supported follow wildcards: * and ?

Use Regular Expressions

Search string contains regular expression.

Dynamic load from file

Enables loading Strings List from external file. File name is set in Strings List. If this option is enabled AEP reloads the file for each processed message.

Import

Loading Strings List from file.

Result Action

Determines the result of the filter.

Pass Message - if search string found filter allows processing of the message by this rule.
Decline Message - if search string found filter denied processing of the message by this rule.

Strings list

List of the string that filter will look in this part of the message


Size Filter
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to filter messages by size.

Larger than

Set the largest message size.

Smaller than

Set the smallest message size.

AND, OR

The logical operation for selecting range of values.


Account Filter
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to filter messages downloaded with the specified account.

Select Account

Set the Account messages downloaded with are to be processed.

Remarks

If the account set in the filter is deleted, the filter will work improperly.

See also

Accounts Window


Filter Group
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Allows to combine work results of some filters or filter groups using the specified logical operation (AND, OR).

Operation with Group Components

Set the logical operation which is used to combine work results of filters and filter groups.


Processing Components
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Processing Components are used to parse, modify, and store data from messages. You can see all the processing components in the Components Palette.

There are the following processing components in AEP

Type | Component | Description
Parsers Used to parse data from messages and to place the data parsed in variables specified by a user. | Line Parser | Line-by-line data parsing.
 | Block Parser | Block-by-block data parsing.
 | Date Parser | Conversion of line with time into user's format.
 | Regular Expression Parser | Data parsing using regular expressions.
Processors Used to modify and store the data parsed. | Set Value by Template | Setting variable value by template.
 | Set Value By File Template | Setting variable value by template from file.
 | Attachments Writer | File attachments saving.
 | File Writer | Writing template to file.
 | Calculator | Calculator is used to perform arithmetic operations with variables.
 | Database Access | Work with databases.
 | Simple Database Access | Easy exchange of data with the database table.
 | SMTP Sender | Sending template via e-mail.
 | Message Sender | Used for automatic resending of a received message through specified mail server.
 | SMS Sender | Used for sending SMS-messages to GSM cellular phones.
 | Run dynamic library | Used for data processing with dynamic library functions.
 | Run executable | Used to process data with executable files.
 | HTTP Reader | Used to read multiple web-pages. Allows to assign query parameters for every page and response text variable to be parsed in.
 | HTML Printer | Used to print out HTML templates.
 | Excel Access | Used to exchange data with MS Excel documents.
Actors While being executed don't modify variable values in the Rule. | Debug Alert | Displays debug information in the message box or records it in the Log.
 | Message Actor | Allows control of message position in account folders and changing its marks while its processing is in progress.
 | Stopper | Used to terminate Rule processing.
 | Iterator Stopper | Used to terminate Iterator processing.
 | Next Iteration | Used to continue with the next iteration during Iterator processing.
Scripting Components Contain the source code in the scripting language used for data processing. | JScript Component | JScript support.
 | VBScript Component | VBScript support.
 | PerlScript Component | PerlScript support.
 | PythonScript Component | PythonScript support.
 | RubyScript Component | RubyScript support.
Conditions Used to select processing components depending on specified variable value. | Simple Condition | User-set variable is used for checking.
 | Result Condition | Result of previous processing components execution is used for checking.
 | Condition Group | Allows choosing of one of several possible conditions for execution. Condition group is a convenient tool for multivariant message processing. Conditions in a group are checked one by one, and the first condition found true is used for processing.
Iterators Used to execute a set of components for lines, blocks, words and regular expressions in the text source. | Word Iterator | Used to execute a set of components for words in specified text source.
 | Line Iterator | Used to execute a set of components for lines in specified text source.
 | Block Iterator | Used to execute a set of components for blocks in specified text source.
 | Regular Expression Iterator | Used to execute a set of components for regular expressions in specified text source.
 | Excel Iterator | Executes a set of components for lines on the specified sheet in MS Excel document.
 | Database Iterator | Executes a set of components for each record from SQL query.
Modifiers Used for modification of text sources and message parts. | Line Modifier | Used for the line modification of the text source.
 | Block Modifier | Used for the block modification of the text source.
 | Regular Expression Modifier | Used for modification of text sources using regular expressions.
 | Simple Modifier | Used for modification of text sources with using simple deletion and converting actions.
 | Message Parts Modifier | Used for modification of message parts.
 | Attachments Modifier | Used to add or remove attachments in messages.

To exchange data between components, variables are used.

A processing component can terminate processing if an error occurs. To enable this function, check the Safe box in the component context menu.

See also

Introduction to Regular Expressions

Constructor Window


Parsers
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Parsers are processing components used to parse data from source text. Both messages (header fields and message body) and variables can be used as text sources.

The parsers are placed into the Parsers folder of the Components Palette.

The following parsers are available in AEP

Component | Description
Line Parser | Line-by-line parsing is used to parse data from source text with search line beginning and end conditions. Search runs throughout the entire text until the search line is found.
Block Parser | Block-by-block parsing is used to parse data from source text with search data block beginning and end conditions. Block may contain several lines.
Date Parser | Designed to convert line with time into user's format.
Regular Expression Parser | Designed to parse data from text sources using regular expressions. Data are parsed in the variables list.
Message Parser | Designed to parse data from a specified message parts to variables .


Line Parser
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Line-by-line parsing allows to parse data from text sources using search line begin and end condition. Search runs throughout the entire text until the search line is found.

Source

Set the source text data to be parsed from.

Start After

Set condition for the beginning of the line to be parsed. The following operation modes are possible:

Begin of Line - The search string starts at begin of a line.

Defined Text - The search string starts after the specified text in a line. Template usage is possible.

Defined Text at Begin of Line - The search string starts after the specified text at begin of a line. Template usage is possible.

Match Case

Enables case-sensitive search of the string beginning.

Use Wildcards

Enables wildcards usage for search of the string beginning.

Use Regular Expressions

Enables regular expressions usage for search of the string beginning.

Include Defined Text into Result

Enables the addition of defined text to the beginning of the string parsed.

Remove Spaces

Enables space deletion at the beginning of the string parsed.

Continue Until

Set condition for end of the line to be parsed. The following operation modes are possible:

End of Line - The search string ends at the end of a line.

Defined Text - The search string ends before the specified text in a line. Template usage is possible.

Defined Text at End of Line - The search string ends before the specified text at the end of a line. Template usage is possible.

Match Case

Enables case-sensitive search of the string end.

Use Wildcards

Enables wildcard usage for search of the string end.

Use Regular Expressions

Enables regular expressions usage for search of the string end.

Include Defined Text into Result

Enables addition of defined text to the end of the string parsed.

Remove Spaces

Enables space deletion at the end of the string parsed.

In Result

Actions made with the result

Return Full String

Enables whole line extraction for the found string.

Ignore Empty Strings

Enables skipping of empty strings.

Output Variable

Set name of the variable data to be parsed in.

See also

Block Parser


Block Parser
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Block-by-block parsing is used to parse data from source text with search data block beginning and end conditions. Block may contain several lines.

Source

Set the source text data to be parsed from.

Start After

Set condition for beginning of the block to be parsed. The following operation modes are possible:

Begin of Data - The block starts at the beginning of the data source.

Defined Text - The block starts after the specified text.

At begin of line

Enables checking that the block beginning found is at the beginning of a line

Whole Text

Enables comparison mode in which defined text must completely coincide with the beginning of the block.

Match Case

Enables case-sensitive search for the block beginning.

Use Wildcards

Enables search for the block beginning using wildcards.

Use Regular Expressions

Enables search for the block beginning using regular expressions.

Include Defined Text into Result

Enables addition of defined text to the beginning of the block parsed.

Block Continue Until

Set block end condition. The following operation modes are possible:

End of Data - The block ends at the end of a text source.

Defined Text - The block ends before the text specified.

Defined Text or End of Source - The block ends before the text specified. If this text not found the blocks ends at the end of source.

At begin of Line

Enables checking that the block beginning found is at the beginning of a line.

Whole Text

Enables comparison mode in which defined text must completely coincide with the end of the block.

Match Case

Enables case-sensitive search for the block end.

Use Wildcards

Enables search for the block end using wildcards.

Use Regular Expressions

Enables search for the block end using regular expressions.

Include Defined Text into Result

Enables addition of defined text to the end of the block parsed.

In Result

Actions made with the result

Remove Empty Lines

Enables empty line deletion in the data parsed.

Ignore Empty Blocks

Enables skipping of empty blocks.

Output Variable

Set name of the variable data to be parsed in.

See also

Line Parser


Date Parser
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Designed to convert a line with time into user's format. Regional setting and user-defined formats are used for conversion.

Source

Sets source type and name of the variable time to be parsed from.

Format Options

Sets the source format settings.

Format

Sets format of the line with time in the defined variable.

Language

Sets regional settings for the line in the defined variable.

Example

Shows the example of line with time for current settings.

Format Result

Sets the result line creation settings.

Format

Sets format of the line to be created

Language

Sets regional settings for the line to be created.

Example

Shows example of a line for current settings.

Adjust Time Zone

Enables changing time zone of the time being converted into local time zone.

Output Variable

Sets name of the variable the result to be placed into.

Date formats

Format | Meaning | Example
d | Day of the month as digits without leading zeros for single digit days. | 5
dd | Day of the month as digits with leading zeros for single digit days. | 05
ddd | Day of the week as a three letter abbreviation. | Mon
dddd | Day of the week as its full name. | Monday
M | Month as digits without leading zeros for single digit months. | 1
MM | Month as digits with leading zeros for single digit months. | 01
MMM | Month as a three letter abbreviation. | jun
MMMM | Month as its full name. | June
y | Year represented only by the last digit, if the year is less than 10. Years greater than 10 will be given the value of yy. | 9
yy | Year represented only by the last two digits. | 09
yyyy | Year represented by the full 4 digits. | 1909

Time format

Format | Meaning | Example
h | Hours without leading zeros for single digit hours (12 hour clock). | 1
hh | Hours with leading zeros for single digit hours (12 hour clock). | 01
H | Hours without leading zeros for single digit hours (24 hour clock). | 1
HH | Hours with leading zeros for single digit hours (24 hour clock). | 01
m | Minutes without leading zeros for single digit minutes. | 9
mm | Minutes with leading zeros for single digit minutes. | 09
s | Seconds without leading zeros for single digit seconds. | 5
ss | Seconds with leading zeros for single digit seconds. | 05
t | One character time marker string. This will be the first letter of the values in the AM symbol or PM symbol boxes in Regional Options. | A
tt | Multi-character time marker string. This will be values in the AM symbol or PM symbol boxes in Regional Options. | AM


Regular Expression Parser
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Designed to parse data from text sources using regular expressions. Data are parsed in the variables list.

Source

Set the text source data to be parsed from.

Method

Comparing methods. Match return True if the whole string matches the given pattern. Search tries to find a substring that matches the pattern.

Expression

Set the regular expression.

Output Variables

The list of variables data to be parsed to.

See also

Regular Expressions Flags


Message Parser
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to parse data from a specified message part.


Processors
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Processors are processing components used to modify and store data parsed from messages.

Processors are placed in the Processors folder in the Components Palette

There are the following processors in AEP

Component | Description
Attachments Writer | Used for file attachments saving.
File Writer | Used to write data into a text file
Calculator | Calculator is used to perform arithmetic operations with variables.
Database Access | Used to exchange data with databases
Simple Database Access | Designed for easier exchange of data with the specified table in the database.
Excel Access | Used to exchange data with MS Excel documents.
SMTP Sender | Used to send e-mail messages
Message Sender | Used for automatic resending of a received message through specified mail server.
SMS Sender | Used for sending SMS-messages to GSM cellular phones. SMS-messages are sent through the Internet using special services.
Run dynamic library | Used for data processing with dynamic library functions
Run executable | Used to process data with executable files
Set Value By Template | Used to set variable value using template
Set Value By File Template | Used to set variable value using template from a text file
HTML Printer | Used to print out HTML templates.
HTTP Reader | Used to read multiple web-pages in text format and save it to variable.
Web Downloader | Used to download any files via HTTP protocol.
Zip Processor | Used to compress files or folders.

For specific processing use Script Components

See also

Scripting Components


Attachments Writer
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Designed to write message attachments in files. File names are stored in the variable list.

Output Directory for Attachment Files

Set the name of directory attachment files to be created in. Template usage is possible.

Filter by source file name

Filters by source file name (wild masks allowed delimited by semicolon)

Exclude

This check box invert condition (not allow files with these file names)

Variable List for File Names

The list of variables which are stored attachment file names.

Remarks

File name is set by merging Output Directory and attachment name modified with settings on the Advanced tab.

Variables are initialized in the order of attachments listing in an e-mail message. If the number of attachments is smaller than number of variables, an empty line will be written in excess variables. If the number of attachments is greater than the number of variables in the list, excess attachments will be ignored.

Store All File names Into Variable

Set variable name all file names to be stored in. File names will be separated by new line symbols.

Sub Directory Name

Set the name of sub directory attachments to be written in.

Prefix

Set the string to be added at the beginning of sub directory name. Template usage is possible.

Add Date

Enables addition of date to the sub directory name. Set format of the siring to be added in the text field.

Add Time

Enables addition of time to the sub directory name. Set format of the string to be added in the text field.

Add Unique Identifier

Enables addition of a unique identifier to the end of sub directory name. Set the identifier length in the number field.

Output File Name

Set template of name of the file attachments to be written in.

Prefix

Set the string to be added in the beginning of file name. Template usage is possible.

Add Date

Enables addition of date to the file name. Set format of the string to be added in the text field.

Add Time

Enables addition of time to the file name. Set format of the string to be added in the text field.

Add Unique Identifier with Length

Enables addition of a unique identifier to the end of file name. Set the identifier length in the number field.

Sample

Shows how the file name would look with current settings.

Date formats

Format | Meaning | Example
d | Day of the month as digits without leading zeros for single digit days. | 5
dd | Day of the month as digits with leading zeros for single digit days. | 05
ddd | Day of the week as a three letter abbreviation. | Mon
dddd | Day of the week as its full name. | Monday
M | Month as digits without leading zeros for single digit months. | 1
MM | Month as digits with leading zeros for single digit months. | 01
MMM | Month as a three letter abbreviation. | jun
MMMM | Month as its full name. | June
y | Year represented only by the last digit, if the year is less than 10. Years greater than 10 will be given the value of yy. | 9
yy | Year represented only by the last two digits. | 09
yyyy | Year represented by the full 4 digits. | 1909

Time formats:

Format | Meaning | Example
h | Hours without leading zeros for single digit hours (12 hour clock). | 1
hh | Hours with leading zeros for single digit hours (12 hour clock). | 01
H | Hours without leading zeros for single digit hours (24 hour clock). | 1
HH | Hours with leading zeros for single digit hours (24 hour clock). | 01
m | Minutes without leading zeros for single digit minutes. | 9
mm | Minutes with leading zeros for single digit minutes. | 09
s | Seconds without leading zeros for single digit seconds. | 5
ss | Seconds with leading zeros for single digit seconds. | 05
t | One character time marker string. This will be the first letter of the values in the AM symbol or PM symbol boxes in Regional Options. | A
tt | Multi-character time marker string. This will be values in the AM symbol or PM symbol boxes in Regional Options. | AM

Remarks

·File creation date and time are used in date and time adding to the file name.

·For using format symbol (d, M, y, h, H, m, s, t, g) in the file name enter single quote before it.

See also

Processors


Set Value By Template
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to set variable value using template.

Template

Set template. To insert a variable value in the output text, it looks in the template as <%variable name%>

Output Variable Name

Set name of the variable the result to be placed in

See also

Processors

Set Value By File Template


Set Value By File Template
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to set variable value using template from a text file.

Variable Name

Set name of the variable the result to be placed in.

Template Filename

Set name of the file that contains the template.

See also

Processors

Set Value By Template


File Writer
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to write data to a text file.

Output File Name

Set name of the output file. If the file doesn't exist, it will be created. Check the Unique Names box to set the directory name. Templates usage is possible.

Template

The template used for writing to a file.

Options

Generate Unique Names

Enable the mode of creating files with unique names.

Prefix

Set prefix of the unique file names.

Extension

Sets unique file extension.

Save Output name

Sets the name of the variable unique file name to be stored into.

Append To File

Data are added to the file end.

Write As UTF16 (Unicode)

Write content in UNICODE

Use Codepage

Write content in specified codepage.

New File Template

Set text template which is added to the begin of created file.

See also

Processors


Calculator
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Calculator is used to perform arithmetic operations with variables. Except for standard operations like "Addition" and "Subtraction", it is possible to use logarithmic and trigonometric functions. Also, this component can be used to transform numeric data to text data in different formats.

Function

The edit box where you are entering text of the function. Template usage is possible.

Result Variable

The variable's name is set here, and the value returned by the function is placed here.

Result Format

Created results are set here. The results can be presented in one of the formats:

%[ flags ] [ width ] [ . precision ] type-char

flags is a sequences of any of those:

Flag | Meaning | Format | Example
- | left alignment | %-10d | 100
= | centered alignment | %=10d | 100
+ | show sign even for positive numbers | %+d | +100
# | show numerical base, and decimal point | %#x | 0x64
0 | pad with 0's (inserted after sign or base indicator) | %05d | 00100
 | if the string does not begin with + or -, insert a space before the converted string | % 7d | 100

width specifies a minimum width of the string resulting after the conversion. If necessary, the string will be padded with alignment and fill characters either set on the stream via manipulators, or specified by the format-string (e.g. flags '0', '-', ..)

precision (preceded by a point), sets the precision

When the result a floating type number, it sets the maximum number of digits

after the decimal point when in fixed or scientific mode

in total when in default mode ('general mode', like %g)

When used with type-char s or S it takes another meaning : the conversion string is truncated to the precision first chars. (Note that the eventual padding to width is done after truncation.)

type-char:

Flag | Meaning | Format | Example
p or x | hexadecimal output | %x | 0x64
o | octal output | %o | 144
e | scientific float format | %e | 3.333333e-001
f | fixed float format | %f | 0.333333
g | general -default- float format | %g | 0.333333
X, E or G | same effect as their lowercase counterparts, but using uppercase letters for number outputs. (exponents, hex digits, ..) | %X | 0X64
d, i or u | decimal type output | %d | 100
s or S | string output | %s | 100
c or C | 1-character output | %c | 1
% | print the character % | %% | %

Examples:

Format | Result
Total %d numbers | Total 25 numbers
Found at 0x%08x | Found at 0x00000200
Result is %e | Result is 3.333333e-001

See also

Processors


Database Access
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to exchange data with databases using ODBC interface.

Data Source

List of available data sources.

Caching

The description of the Caching Tab see in the article Caching in components working with data servers.

SQL expression

Set SQL request for work with a database. Template can be used in the request text.

Database Columns, Output Variables

Set the request columns data to be sent from and the variables data to be sent to. Templates can be used for column names.

Replace single quote to double in variables

Replace single quote to double in variables.

Dynamic data binding

Enables the mode of working with a database where writing of long data is possible, regardless of SQL request length limitation.

Query can't Update Data

Query can't Insert Data

Query can't Delete Data

Flags used to optimize database queries

Remarks

To use this component, you must have Microsoft Data Access Components 2.5 or newer installed on your computer. For more details about MSDAC visit the Universal Data Access web-site.

See also

Database Iterator

Processors


Simple Database Access
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used for easier work with databases. The component executes one action with the specified table. It can be used for select, adding, updating, and removal of entries using the specified condition. A list of variables is used for exchanging data with the entries. Each variable equals a field in the table. When setting a variable for a field, field type is to be specified. Field type determines the direction of data exchange between the variable and the field.

Data Source

List of available data sources.

Caching

The description of the Caching Tab see in the article Caching in components working with data servers.

Select Table

Specifies the table in the data source, which the action is to be executed for.

Action

Sets the action to be executed for the specified table. The following actions are possible:

Select Data - Get one entry from the table. The values are returned into the result-type fields. For entry selection, fields of the key, autokey, and search types are used.

Insert Data - Add one entry to the table. For fields of the autokey type, maximum field values are returned.

Update Data - Update several existing entries in the table. For entry selection, fields of the key and search types are used.

Delete Data - Remove several entries from the table. For entry selection, fields of the key, autokey, and search types are used.

Insert or Update Data - Update existing entries in the table or add a new one. For entry selection, fields of the search types are used. If some entries are found, they will be updated. If there are no entries, a new entry will be added, like with Update Data.

Field, Type, Variable

Sets the correspondence list for table fields and variables, as well as field types. The following field types are used:

Unused - The field is not used when exchanging data.

Key - The variable is used for selection by key field.

Autokey - The variable is used to get automatic counter value.

Search - The variable is used for selection by variable field.

Update - The variable contains a value stored in the field. If an expression in the Variable column can be put in parentheses, it is substituted as a part of SQL expression, not as a variable value. For the format for Insert or Update Data, see the note.

Result - The variable is used to store the field value upon action execution.

Remarks

·For the Insert or Update Data action, the / symbol can be used as a separator of expressions used in Insert and Update

Syntax

Insert expression/Update expression.

Examples:

(1)/(MSGCOUNT+1)

StartNo/(MSGCOUNT+1)

MsgNo/()

·If there is no separator, the same expression is used both for Insert and for Update.

·If there is no need to change field value when updating, leave empty expression or empty parentheses after the separator.

Detailed description of the actions

The actions used in the component are converted into one or several SQL requests. Below are some examples of how this works.

Assume we have a table named CLIENT, which stores client's name and surname, his e-mail address, date of registration, and number of messages received from that client.

Field | Type | Description
ID | COUNTER | Client identifier
REGDATE | DATETIME | Registration date
FIRSTNAME | TEXT | Client name
LASTNAME | TEXT | Client surname
EMAIL | TEXT | Client e-mail address
MSGCOUNT | NUMBER | Number of received messages

The examples below show what requests will be executed for each action.

Select Data

To parse data from the table into variables, the Select Data action is used. Assume you need to find out identifier and registration date of a registered client based on his e-mail address.

Assigning fields to values

Field | Type | Expression
ID | Result | Id
REGDATE | Result | RegDate
FIRSTNAME | Unused |
LASTNAME | Unused |
EMAIL | Search | SenderEmail
MSGCOUNT | Unused |

The component will execute the following request:

SELECT ID, REGDATE FROM CLIENT WHERE EMAIL='<%SenderEmail%>';

The request result will be placed into variables assigned to fields to be obtained in the request, i.e. Id and RegDate.

Insert Data

To add data about a client, the Insert Data is to be used. Assume you need to parse client's name and surname from a message into variables, the current date is to be written to the REGDATE field, and "1" is to be written into the MSGCOUNT field. Besides, it is necessary to get identifier of the new entry about a client.

Assigning fields to values:

Field | Type | Expression
ID | Autokey | Id
REGDATE | Update | RegDate
FIRSTNAME | Key | FirstName
LASTNAME | Key | LastName
EMAIL | Key | SenderEmail
MSGCOUNT | Update | (1)

The component will execute the following requests:

INSERT INTO CLIENT (REGDATE, FIRSTNAME, LASTNAME, EMAIL, MSGCOUNT)

VALUES('<%RegDate%>', '<%FirstName%>', '<%LastName%>','<%Email%>', 1);

SELECT MAX(ID) FROM CLIENT

WHERE FIRSTNAME='<%FirstName%>' AND LASTNAME='<%LastName%>' AND EMAIL='<%Email%>';

The result of the last request will be stored in variable of the autokey type, i.e. Id.

Update Data

To update data in the table entries, the Update Data action is used. Assume you need to increase message counter for a client with given e-mail address by 1.

Assigning fields to values:

Field | Type | Expression
ID | Unused |
REGDATE | Unused |
FIRSTNAME | Unused |
LASTNAME | Unused |
EMAIL | Key | SenderEmail
MSGCOUNT | Update | (MSGCOUNT+1)

The component will execute the following request:

UPDATE CLIENT SET MSGCOUNT=(MSGCOUNT+1)WHERE EMAIL='<%Email%>';

Delete Data

To delete, the Delete Data action is to be executed. Assume you need to delete entries about clients named John.

Assigning fields to variables:

Field | Type | Expression
ID | Unused |
REGDATE | Unused |
FIRSTNAME | Search | FirstName
LASTNAME | Unused |
EMAIL | Unused |
MSGCOUNT | Unused |

The component will execute the following request:

DELETE FROM CLIENT WHERE FIRSTNAME='<%FirstName%>';

Insert or Update Data

To add entries with checking for existence, use the Insert or Update Data action. Assume you need to increase the message counter for a client with given name, surname, and e-mail address, and if there is no such client in the table, to create a new entry. Identifier of the found or new client is to be stored in the Id variable.

Assigning fields to variables:

Field | Type | Expression
ID | Autokey | Id
REGDATE | Update | RegDate/()
FIRSTNAME | Search | FirstName
LASTNAME | Search | LastName
EMAIL | Search | Email
MSGCOUNT | Update | (1)/(MSGCOUNT+1)

The components will execute the following requests:

SELECT ID FROM CLIENT

WHERE FIRSTNAME='<%FirstName%>' AND LASTNAME='<%LastName%>' AND EMAIL='<%Email%>';

If no identifier is found, the component will execute the new entry adding request:

INSERT INTO CLIENT (REGDATE, FIRSTNAME, LASTNAME, EMAIL, MSGCOUNT)

VALUES('<%RegDate%>', '<%FirstName%>', '<%LastName%>','<%Email%>', 1);

Otherwise, the existing entry update request will be executed:

UPDATE CLIENT SET MSGCOUNT=MSGCOUNT+1

WHERE ID=[found with SELECT ID];

Finally, the request for getting autokey field will be executed:

SELECT MAX(ID) FROM CLIENT;

The result of the last request will be stored in the autokey type variable, i.e. Id.

Remarks

To use this component, you must have Microsoft Data Access Components 2.5 or newer installed on your computer. For more details about MSDAC visit the Universal Data Access web-site.

See also

Database Access

Database Iterator

Processors


SMTP Sender
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to send e-mail messages.

From

Set sender name and address. Template usage is possible.

To

Set recipient name and address of primary recipient. Template usage is possible.

Subject

Set message subject. Template usage is possible.

Body selection List Box

Select edited body type.

Load Message

Allow filling of fields from message file. Can be used to send HTML messages.

Body

Set body (Text or HTML). Template usage is possible.

OPTIONS

Encode Headers

Specify whether foreign character sets, high ASCII, or double-byte character sets (DBCS) are allowed in the header without encoding. Select encoding method for these characters.

Encode Text Part

Set bit and binary formats for encoding Text part of the message.

Encode HTML Part

Set bit and binary formats for encoding HTML part of the message.

Default Codepage

Set the character set standard that will be used for default codepage.

Encode Attachments

Encode attachments with selected encoding

Attached Files

Setup attached files. Template and wildcards usage is allowed.

CC

Carbon Copy to secondary recipients

BCC

Blind Carbon Copy to tertiary recipients who receive the message. The primary and secondary recipients cannot see the tertiary recipients.

Sender (MAIL FROM substitution)

Value of the "MAIL FROM" property - who the message is sent from. If the box is not ticked, the value from the From field is used.

Recipient (RCPT TO substitution)

Value of the "RCPT TO" property - who the message is sent to. If the box is not ticked, the value from the To field is used.

Custom header fields

Set values of the specified fields of the message header. Template usage is possible.

Domain for "HELO"

Set the domain name used by SMTP-server for greeting. Using your domain name is recommended. Using another name is possible, though not recommended. If no name is set, the program will try to define it automatically.

Server

Set outgoing mail server (SMTP).

Port

Set outgoing mail server port number. For SMTP this number is usually 25.

Use Default

Restore the server port number to it's default setting.

Connection

Combo box with following selection:

Regular - Typical SMTP protocol

Secure to regular port (STARTTLS) - STARTTLS is an extension to plain text communication protocols, which offers a way to upgrade a plain text connection to an encrypted (TLS) connection instead of using a separate port for encrypted communication.

Secure to dedicated port (TLS) - Encrypted communication for SMTP to the server using Transport Layer Security (TLS).

Require authentication

Check this box, if user authorization is required by the mail server to send a message.

Account Name

User name used to access the mail server.

Password

Password used to access the mail server.

Timeout

Set waiting time when working with outgoing mail server. If your connection is fast, move the slider closer to "Short". If your connection is slow, or the mail server is heavily loaded, move the slider towards "Long".

See also

Processors


Message Resender
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used for automatic resending of a received message through specified mail server.

This action differs from regular forwarding of a message. When forwarding a message, a new message is created, and the whole original message, including its body and heading, is copied into body of the new message. Resending leaves the original message body intact, only changing the fields in its heading. In this instance, recipient will actually receive the original message, but from another sender.

The Message Sender provides for complete processing of the original message heading, setting up connection with the relevant mail server, and sending the message to that server. Message is sent using the SMTP protocol, and the mail server should allow receiving for the sender's address and sending for the recipient's address. Otherwise, the server will deny sending the message.

Replace Message Fields

Replacement of the information in main fields of original message heading. Tick the relevant box and type new data in the text field to the right of it.

From

The "From" field in message heading - sender's address. If the field is empty, original message sender's address is used.

To

The "To" field in message heading - recipient's address. If the field is empty, original message recipient's address is used.

Subject

The "Subject" field in message heading - message subject. If the field is empty, original message subject is used.

Server Substitutions

Values substituted into the SMTP protocol properties for exchange with the specified mail server. To enable substitution, tick the relevant box and type the new value in the text field right of it.

Sender

Value of the "MAIL FROM" property - who the message is sent from. If the box is not ticked, the value from the From field is used.

Recipient

Value of the "RCPT TO" property - who the message is sent to. If the box is not ticked, the value from the To field is used.

Options

Create Resent Fields

Check this box if you want the information about current resending to be added to the message. Then, the message sender will add the "Resent-*" fields to the message heading. These fields will contain the information on who and when resend the message.

Remove Transport Fields

These fields - "Received" and "X-*" - contain the information about original message delivery root. Check this box, if you don't want this information to be enclosed with the message you are resending.

CC

Carbon Copy to secondary recipients

BCC

Blind Carbon Copy to tertiary recipients who receive the message. The primary and secondary recipients cannot see the tertiary recipients.

Custom header fields

Processing of additional fields in the message heading. Type the field name and its value in the editing box, as you want them to appear in the message you are resending (e.g., "X-Mail-From: AEP"). If the message already contains such fields, they will be replaced with new values.

Domain for "HELO"

Name of the mail server's domain it communicates to other SMTP servers.

It is recommended that you enter your real domain name. If no domain name is entered, the program will try to detect it automatically. If detection fails for some reason, the domain name localhost will be used. Usage of the localhost alias or of another domain name is not prohibited; however, in this instance some servers with high security level would deny working with your mail server.

If you connect to the Internet via a proxy server using the Socks5 protocol, you must enter the proxy server domain name, because its automatic detection is impossible.

Server

Name of the mail server you're resending the message to.

Port

Port number on that server.

Use Default

Click this button to use default port number (Port 25).

Connection

Combo box with following selection:

Regular - Typical SMTP protocol

Secure to regular port (STARTTLS) - STARTTLS is an extension to plain text communication protocols, which offers a way to upgrade a plain text connection to an encrypted (TLS) connection instead of using a separate port for encrypted communication.

Secure to dedicated port (TLS) - Encrypted communication for SMTP to the server using Transport Layer Security (TLS).

Require authentication

Check this box, if user authorization is required by the mail server to send a message.

Account Name

User name used to access the mail server.

Password

Password used to access the mail server.

Timeouts

Set mail server connection timeout values. Move the slider to the desired position between Short and Long.

See also

Server Settings

SMTP Sender


SMS Sender
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used for sending SMS-messages to GSM cellular phones. SMS-messages are sent through the Internet using special services. These services are accessed either via special servers or via web-sites of cellular operators.

The only thing you have to do to send a message using the SMS Sender is to enter its text and the mobile phone number, provided you have already configured the sender properties.

Sending Method

The list of available methods of sending SMS-messages to Internet servers supporting SMS.

Phone Number

Mobile phone number you want to send SMS-message to.

Message Text

The edit box you are to type SMS-message text in.

Server

Internet-address of the server that will be used to send an SMS-message.

Port

Number of the SMS service port on the Internet-server. This is an individual property of each particular server. Normally, its value is available on the relevant information page.

User name

User name used to send an SMS-message, if authorization is required.

Password

User password used to send an SMS-message, if authorization is required.

See also

Server Settings

SMTP Sender

Message Sender


Run Dynamic Library
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used for data processing with dynamic library functions. A processor loads a dynamic library and invokes function specified by a user, sending required data there.

DLL file name

Set the name of a dynamic library. Template usage is possible.

Function name

Set name of the function to be invoked. Template usage is possible.

Function parameters

Set parameters to be sent to the function. Template usage is possible.

Change directory to DLL location

Enable changing current directory to DLL folder before loading DLL. It's helpful when loaded DLL uses another libraries.

Result Variable

Set name of the variable the value returned by the function to be placed in.

Remarks

Functions invoked from dynamic libraries used in the Run dynamic library processor must be implemented according to the following prototype:

BSTR UserFunction( BSTR bstrParameter1, BSTR bstrParameter2, BSTR bstrParameter3, BSTR bstrParameter4, BSTR bstrParameter5);

DLL must have same bitness as AEP due limitation of the Windows. The 64-bit process can't load 32-bit DLL and vice versa.

See also

Processors


Run Executable
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to process data with executable files. Data can be sent to the program using the command line and standard input.

Executable file name

Set the application executable name. Template usage is possible.

Command line

Set the command line to be used for the program launch. Template usage is possible.

Do not wait for executable termination

AEP does not wait when the program terminates and continues processing the next component. In this mode working with STDIN and STDOUT not possible.

Execution timeout

The time waiting for the end application execution. If set to zero, AEP will wait until the program terminates. Warning: this may possible to lock AEP

Change the directory to the location

Enable changing the current directory to another folder before executing the application. If a directory is not set then used path in the application file name. If option unchecked by default working directory is an AEP installation path.

Do not use data for STDIN of executable

AEP does not use the STDIN pipe for transfer data to the application. If option unchecked you can set data to be sent to the program through the standard input. Template usage is possible.

Do not grab STDOUT to variable

AEP ignores data from the STDOUT pipe that can be sent by the program. Otherwise, all data from standard output will be placed into a variable.

Result Variable

Set name of the variable the value returned by the program upon execution to be placed in.

See also

Processors


HTTP Reader
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to read multiple web-pages. Allows assignment of query parameters for every page and response text variable to be parsed in.

Component does not support binary data and can be used only for HTML pages or text files. See Web Downloader component.

Requested URL's

Set list of web addresses of requested URL. Template usage is possible.

Selected URL Options

Contains parameters for chosen web address in Requested URLs. The following parameters are assigned:

Use authentication

Select if target URL requests authorization.

Parameters request Method

Set posting method of query parameters (GET or POST).

Name, Value

Set list of query parameters. In both columns template usage is possible. If the name of any parameter is incorrect (e.g. empty), then it will be ignored.

Page encoding

Convert the received HTML page to Unicode from the specified code page.

Output Variable

Set variable name from query response text to be placed in.

Status Variable

Set variable name from the query result status to be placed in.

Request Timeout

Set time-out from HTTP server, whereupon connection will be closed. This time is equally for every requested URL. If your connection with HTTP server is fast, move the slider towards Short. If your connection with HTTP server is slow or the server is heavily loaded, move the slider towards Long.

See also

Processors


HTML Printer
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to print out HTML template.

HTML template

Set HTML template to be printed out.

Page Setup

Changes the page layout and printer settings.

See also

Processors

File Writer

HTTP Reader


Excel Access
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to exchange data with MS Excel documents. Data are read/stored from/to the first line or all lines in the specified worksheet's range. Data exchange is made using a list of variables specified in the component. Variables in the list correspond to columns on the worksheet, i.e. the first variable exchanges it's value with cells in the first column, the second - with cells in the second column etc.

Workbook

Set Excel workbook file name.

Worksheet

Set worksheet name, which is used to exchange data.

Action

Set the action and direction of data exchange. The following actions are possible:

Read Data Cells - Reading data from cells of the line found by the condition specified below. The extracted data are transferred into the variables specified in the component by the list. If the condition is not specified the first line of specified range will be read.

Append Data Cells - Appending data from variables into cells of the first empty line after the line found by the condition given below. If the condition is not specified the first empty line in the range will be used.

Replace Data Cells - Replacement of the data in cells of the line found by the condition specified below. The new data is taken from the variables given in the component by the list. If the condition is not specified, replacement will not be made and the component sets a failed state.

Replace or Append Data Cells - Data replacement or data addition into cells of the line found by the condition specified below. The new data is taken from the variables given in the component by the list. If the condition is not specified the first empty line in the range will be used.

Caching

The description of the Caching Tab see in the article Caching in components working with data servers.

Data Condition

Set an additional condition on a value in the specified column. Lines for which values in the specified below column do not meet condition, will be ignored.

Where

Set a name of the column for which condition will be used. The name of the column is taken from cells in the first line of the worksheet. I.e. name for the first column takes from cell A1, name for the second column from cell A2, etc.

Condition

Set the condition on value for the column specified in Where.

Result

Range

Set an area in the worksheet for which lines to be read/stored in. By default the whole worksheet is used.

Data variables

Set the list of variables used for data exchange with cells of involved lines.

Combine Multiply Results

Enables the mode in which cells values of all lines from specified range for each column will be stored in the appropriate variable. A separator of values in the variable is carriage return. Only cells from lines which meet to the specified condition will be used.

Remarks

·To use this component, you must have Microsoft Excel installed on your computer.

·New line is not appended if the specified range does not contain an empty line. The component sets a failed state in this case.

See also

Processors

Database Access


Web Downloader
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to download any files via HTTP protocol. Allows assignment of query parameters for every URL and response text variable to be parsed in.

Requested URL's

Set list of web addresses of requested file. Template usage is possible.

Selected URL Options

Contains parameters for chosen web address in Requested URLs. The following parameters are assigned:

Use authentication

Select if target URL requests authorization.

Parameters request Method

Set posting method of query parameters (GET or POST).

Name, Value

Set list of query parameters. In both columns template usage is possible. If the name of any parameter is incorrect (e.g. empty), then it will be ignored.

Store Path

Folder where downloaded file will be saved. File name will be taken from URL. If URL does not contain document name, index.html will be used.

Overwrite existing file

If the file already exists in the selected path, it will be overwritten, otherwise it will be renamed by template. For example: index.html will be renamed to index (1).html or index (2).html etc.

Output Variable

Set variable name where path of downloaded file will be stored.

Status Variable

Set variable name from the query result status to be placed in.

Store All File Names Into Variable

Set variable name all file names to be stored in. File names will be separated by new line symbols.

Request Timeout

Set time-out from HTTP server, whereupon connection will be closed. This time is equally for every requested URL. If your connection with HTTP server is fast, move the slider towards Short. If your connection with HTTP server is slow or the server is heavily loaded, move the slider towards Long.

See also

Processors


ZIP Processor
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Designed to compress files or folders.

Action

Add - add files to archive

Move - move files to archive. Files removed only if create of zip succeeded.

Compression

List of the available compression algorithm.

Zip file name

Set the name of compressed file. Template usage is possible.

Store Zip to folder

Place where compressed file will be stored

Store file name to Output variable

Store full path and zip name to Variable.

Selecting the location of the files to be archived

Zip Folder

The source files are in a folder.

Include subfolders

Also in the archive are added files from subfolders. The folder structure is retained in archive.

Filter by mask

Filter source files by mask - wildcards allowed and delimited by a semicolon.

Zip Filelist

The source files are in a list.

List of Variables or Files

Support usage of variables and wildcards.

Sub Directory Name

Set the name of sub directory attachments to be written in.

Prefix

Set the string to be added in the beginning of sub directory name. Template usage is possible.

Add Date

Enables addition of date to the sub directory name. Set format of the string to be added in the text field.

Add Time

Enables addition of time to the sub directory name. Set format of the string to be added in the text field.

Add Unique Identifier

Enables addition of a unique identifier to the end of sub directory name. Set the identifier length in the number field.

Output File Name

Set template of name of the file attachments to be written in.

Prefix

Set the string to be added in the beginning of file name. Template usage is possible.

Add Date

Enables addition of date to the file name. Set format of the string to be added in the text field.

Add Time

Enables addition of time to the file name. Set format of the string to be added in the text field.

Add Unique Identifier with Length

Enables addition of a unique identifier to the end of file name. Set the identifier length in the number field.

Sample

Shows how the file name would look with current settings.

See also

Processors


Script Components
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Script Components contain source code in a scripting language used for data processing.

Script Components are placed in the Script Components folder in the Components Palette

There are the following script components in AEP

Component | Description
JScript Component | Used to execute code in JScript language.
VBScript Component | Used to execute code in VBScript language.
Perl Script Component | Used to execute code in Perl Script language.
Python Script Component | Used to execute code in Python Script language.
Ruby Script Component | Used to execute code in Ruby Script language.


Script Components
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Allows to toggle on ActiveX components and process data with them.

Global Variables

The list of global variables that can be used by other Processing Components.

Source Code

Source code in the chosen language.

Remarks

·To use Perl component, you must have Active Perl installed on your computer.

·To use Python component, you must have Active Python installed on your computer.

·To use Ruby component, you must have Ruby and Active Ruby installed on your computer.

See also

Processing Components

Information for programmers


Actors
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Actors are processing components that don't change variable values.

Actors are placed in the Actors folder in Components Palette.

There are following actors in AEP

Component | Description
Debug Alert | Displays debug information in the message box or records it in the Log.
Message Actor | Allows controlling message position in account folders and changing its marks while its processing is in progress.
Stopper | Used to terminate the Rule processing.


Debug Alert
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Displays debug information in the message box or records it in the Log.

Action

Set debug information output method. The following values are possible:

Modal Message Box - Template value is displayed in a message box.

Information Message - Template value is displayed in a popup message.

Write to Log - Template value is recorded into the Log.

Play Sound - Template value is name of a WAV file to be played.

Type

Set the event type.

Action Template

Set the message template.

See also

Rule Debugging


Message Actor
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Allows control of message position in account folders and changing its marks while its processing is in progress.

Select Account

This is the list of accounts.

Actions

The list of actor actions. The following actions are depends on account you use:

Move Message - message is moved to specified folder

Copy Message - message is copied to specified folder

Delete Message - message is removed

Mark as Read - message is marked as read

Unmark as Read - message is marked as unread

Mark as Deleted - message is marked as "deleted"

Unmark as Deleted - the "deleted" mark is removed from a message

Mark as Hidden - message is marked as "hidden"

Unmark as Hidden - the "hidden" mark is removed from a message

Mark as Highlighted - message is marked as "highlighted"

Unmark as Highlighted - the "highlighted" mark is removed from a message

Mark as Tagged - put a special client-defined mark on a message

Unmark as Tagged - remove a special mark from a message

Mark as Flagged - put a user defined flag on a message

Unmark as Flagged - remove a user defined flag from a message

Select Folder

Specify the folder a message is to be copied/moved to.

Set Parameter

Specify the flag for the message is to be set/unset. Details about flags in IMAP v4 protocol you can found at RFC3501.

Remarks

This Actor will be only activated in "Realtime Processing" mode.

Only MAPI and IMAP accounts supported.

See also

Accounts Window


Stopper
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to terminate the Rule processing.

Rule is Exited with Status

Change rule execution status

See also

Conditions


Conditions
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Conditions are processors used to select operations depending on user-specified variable value.

Conditions are placed in the Conditions folder in the Components Palette.

There are the following conditions in AEP

Component | Description
Simple Condition | User-set variable is used for checking.
Try Condition | Declare the start of construction Try-Catch.
Result Condition / Catch | Result of previous processing components execution is used for checking.
Condition Group | Allows choosing one of several possible conditions for execution. Condition group is a convenient tool for multivariant message processing.


Try Condition
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Declare the start of construction Try-Catch.


Result Condition / Catch
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Allows execution of selected operations set depending on the previous processing components result.

Criterion is met if the last component

Set the result to be used for the condition check. The following values are possible:

Succeeded - All previous components have been executed successfully.

Failed - An error occurred during execution of any previous component.

Clear error code (catch)

Component error execution code cleared. If before declared Try Condition allow to reset result of components execution. I.e. avoid to terminate of rule execution if errors occurred.


Text Condition
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Allows execution of selected operations set depending on condition set by user.

Note to users of previous versions

This condition combines the capabilities of the Dictionary and Simple conditions in previous versions of AEP.
These conditions are converted into the Text Condition, if you are upgrading your old configuration or import rules from previous versions of the program.

Source

Set the text source to be used for condition check.

Action.

Empty - True if the text source is empty.

Equals Defined Text - True if the text source is the same as the line specified. Template usage is possible.

Contains Defined Text - True if the text source contains the line specified. Template usage is possible.

Begin With Defined Text - True if the text source begins with the line specified. Template usage is possible.

End With Defined Text - True if the text source ends with the line specified. Template usage is possible.

Dynamic Load From File

Enables loading Strings List from external file. Dictionary file name is set in Dictionary Strings. If this option is enabled AEP reloads the dictionary file for each processed message.

Options

Match Case

Enables case-sensitive comparison.

Use Wildcards

Enables wildcards usage when comparing.

Use Regular Expressions

Enables regular expressions usage when comparing.

Result Action

Pass Message - if search string found condition allows processing of the message by this rule.
Decline Message - if search string found conditon denied processing of the message by this rule.

Strings List

List of strings for comparison


Condition Group
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Allows selection of one of several possible conditions for execution. Condition group is a convenient tool for multivariant message processing. Conditions in a group are checked one by one, and the first condition found true is used for processing.

The work of a group with three conditions A, B and C can be illustrated by the following scheme:

IF A is TRUE, THEN execute the set of processing components for A

ELSE IF B is TRUE, THEN execute the set of processing components for B

ELSE IF C is TRUE, THEN execute the set of processing components for C


Iterators
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Iterators are processing components, used to execute the set of components for lines, blocks, words and regular expressions in the text source.

Iterators are placed in the Iterators folder in Components Palette.

There are the following iterators in AEP

Component | Description
Line Iterator | Execute the set of components for lines in the specified text source.
Block Iterator | Execute the set of components for blocks in the specified text source.
Regular Expression Iterator | Execute the set of components for regular expressions in the specified text source.
Word Iterator | Execute the set of components for words in the specified text source.
Excel Iterator | Executes the set of components for lines on the specified sheet in MS Excel document.
Database Iterator | Executes the set of components for each record from SQL query.
Iterator Stopper | Used to terminate the Iterator processing.
Next Iteration | Used to continue with the next iteration during Iterator processing.


Word Iterator
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to execute a set of components for words in a specified text source. Only words that meet the iterator condition will be processed. For every iteration the next appropriate word is parsed from the text source and placed to the variable. After that the set of iterator components will be executed. Iterator will finish its job, if the word meets its condition was not found.

Source

Set text source from which word will be parsed.

Start After

Set condition for begin of the word to be parsed. The following operation modes are possible:

Begin of Word - The search string starts at begin of a word.

Defined Text - The search string starts after the specified text in a word. Template usage is possible.

Defined Text at Begin of Word - The search string starts after the specified text at begin of a word. Template usage is possible.

Match Case

Enables case-sensitive search of the word beginning.

Use Regular Expressions

Enables regular expressions usage for search of the word beginning.

Include Defined Text into Result

Enables addition of defined text to the beginning of the word parsed.

Remove Spaces

Enables space deletion at the beginning of the word parsed.

Continue Until

Set condition for end of the word to be parsed. The following operation modes are possible:

End of Word - The search string ends at the end of a word.

Defined Text - The search string ends before the specified text in a word. Template usage is possible.

Defined Text at End of Word - The search string ends before the specified text at the end of a word. Template usage is possible.

Match Case

Enables case-sensitive search of the word end.

Use Regular Expressions

Enables regular expressions usage for search of the word end.

Include Defined Text into Result

Enables addition of defined text to the end of the word parsed.

Remove Spaces

Enables space deletion at the end of the word parsed.

Ignore Empty Words

Enables skipping of empty words.

Result Variable

Set variable name, which is used to parse word for every iteration.

Iteration Variable

Set variable name iteration number to be placed in.

Use Text Qualifiers

Set text qualifiers automatically will be removed from parsed words.

Use Custom Delimiter(s)

Set delimiters separating words. By default blank spaces are used.

Words May Contain New Line

Enables ignoring new line symbols in delimiters (custom or default). Therefore parsed words may contain new line symbols.

Words May Contain Spaces

Enables ignoring white space symbols in delimiters (custom or default). Therefore parsed words may contain white spaces.

See also

Iterators

Iterator Break

Iterator Continue


Line Iterator
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to execute a set of components for lines in a specified text source. Only lines that meet the iterator condition will be processed. For every iteration the next appropriate line is parsed from the text source and placed to the variable. After that the set of iterator components will be executed. Iterator will finish its job, if the line meeting its condition was not found.

Source

Set the source text data to be parsed from.

Start After

Set condition for begin of the line to be parsed. The following operation modes are possible:

Begin of Line - The search string starts at begin of a line.

Defined Text - The search string starts after the specified text in a line. Template usage is possible.

Defined Text at Begin of Line - The search string starts after the specified text at begin of a line. Template usage is possible.

Match Case

Enables case-sensitive search of the string beginning.

Use Regular Expressions

Enables regular expressions usage for search of the string beginning.

Include Defined Text into Result

Enables addition of defined text to the beginning of the string parsed.

Remove Spaces

Enables space deletion at the beginning of the string parsed.

Continue Until

Set condition for end of the line to be parsed. The following operation modes are possible:

End of Line - The search string ends at the end of a line.

Defined Text - The search string ends before the specified text in a line. Template usage is possible.

Defined Text at End of Line - The search string ends before the specified text at the end of a line. Template usage is possible.

Match Case

Enables case-sensitive search of the string end.

Use Regular Expressions

Enables regular expressions usage for search of the string end.

Include Defined Text into Result

Enables addition of defined text to the end of the string parsed.

Remove Spaces

Enables space deletion at the end of the string parsed.

In Result

Return Full String

Enables whole line extraction for the found string.

Ignore Empty Strings

Enables skipping of empty strings.

Result Variable

Set name of the variable data to be parsed in.

Iteration Variable

Set variable name iteration number to be placed in.

See also

Iterators

Iterator Break

Iterator Continue


Block Iterator
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to execute a set of components for blocks at the specified text. Only blocks that meet the iterator condition will be processed. For every iteration the next appropriate block is parsed from the text source and placed to the variable. After that the set of iterator components will be executed. Iterator will finish its job, if the block that meets its condition was not found.

Source

Set text source blocks to be parsed from.

Block Start After

Set condition for beginning of the block to be parsed for every iteration. The following operation modes are possible:

Begin of Data - The block starts at the beginning of the data source.

Defined Text - The block starts after the specified text.

Match Case

Enables case-sensitive search for the block beginning.

Line Start Only

Enables checking that the block beginning found is at the beginning of a line

Whole Text

Enables comparison mode in which defined text must completely coincide with the beginning of the block.

Use Regular Expressions

Enables search for the block beginning using regular expressions.

Include Defined Text into Result

Enables addition of defined text to the beginning of the block parsed.

Block Continue Until

Set block end condition. The following operation modes are possible:

End of Data - The block ends at the end of a text source.

Defined Text - The block ends before the text specified.

Defined Text or End of Source - The block ends before the text specified. If this text not found the blocks ends at the end of source.

Match Case

Enables case-sensitive search for the block end.

Line Start Only

Enables checking that the block beginning found is at the beginning of a line.

Whole Text

Enables comparison mode in which defined text must completely coincide with the end of the block.

Use Regular Expressions

Enables search for the block end using regular expressions.

Include Defined Text into Result

Enables addition of defined text to the end of the block parsed.

In Result

Remove Empty Lines

Enables empty line deletion in the data parsed.

Ignore Empty Blocks

Enables skipping of empty blocks.

Result Variable

Set name of the variable block to be parsed in for every iteration.

Iteration Variable

Set variable name, which is used to place iteration number.

See also

Iterators

Iterator Break

Iterator Continue


Regular Expression Iterator
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to execute a set of components for regular expressions in specified text source. At each iteration component will find the next regular expression in the text source. It will be parsed with iterator and stored in set of variables. After all a set of iterator components will be executed. Iterator will finish its job, if the line meeting its condition was not found.

Source

Set text source, which is used to parse data from every iteration.

Method

Comparing methods. Match return True if the whole string matches the given pattern. Search tries to find a substring that matches the pattern.

Expression

Set regular expression.

Result Variables

A list of variables which is used to parse data.

Iteration Variable

Set variable name iteration number to be placed in.

See also

Regular Expressions Flags

Iterators

Iterator Break

Iterator Continue


Excel Iterator
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Executes a set of components for lines on the specified sheet in MS Excel document. Data from each line are transferred into the variables specified in the component by list. Variables in the list corresponds to columns on the worksheet, i.e. the first variable exchanges it's value with cells in the first column, the second - with cells in the second column etc. Iterations will be executed for all lines in the specified range until empty line being extracted.

Select WorkBook

Set Excel workbook file name.

Worksheet

Set worksheet name, which is used to exchange data.

Data Condition

Set an additional condition for a value in the specified column. Lines for which values in the specified below column do not meet the condition, will be ignored.

Where

Set a name of the column for which the condition will be used. The name of the column is taken from cells in the first line of the worksheet. I.e. name for the first column takes from cell A1, name for the second column from cell A2, etc.

Condition

Set the condition on value for the column specified in Where.

Result

Range

Set an area in the worksheet for which lines to be read/stored in. By default the whole worksheet is used.

Data variables

Set the list of variables used for data exchange with cells of extracted lines.

Iteration Variable

Set variable name iteration number to be placed in.

Caching Tab

The description of the Caching Tab see in the article Caching in components working with data servers.

Remarks

To use this component, you must have Microsoft Excel installed on your computer.

See also

Iterators

Iterator Break

Iterator Continue


Database Iterator
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Executes a set of components for each record from SQL query.

Data Source

List of available data sources.

Caching

The description of the Caching Tab see in the article Caching in components working with data servers.

Enter SQL expression

Set SQL request for work with a database. Template can be used in the request text.

Output Variables

Set the list of variables field values to be stored in.

Iteration Variable

Set variable name iteration number to be placed in.

Remarks

To use this component, you must have Microsoft Data Access Components 2.5 or newer installed on your computer. For more details about MSDAC visit the Universal Data Access web-site.

See also

Database Access

Iterators

Iterator Break

Iterator Continue


Simple Iterator
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to execute a set of components by the simple conditions.

Result Variable

Set name of the variable data to be parsed in.

Iteration Variable

Set variable name iteration number to be placed in.

Initial iteration value

A numeric value that starts the iteration.

Step

Value iteration step.

Continue until Variable

Condition for the continuation of iterations.

Less than - while current iteration value less than value set in field.

Greater than - while current iteration value greater than value set in field.

Less or Equal - while current iteration value less or equal than value set in field.

Greater or Equal - while current iteration value greater or equal than value set in field.

See also

Iterators

Iterator Break

Iterator Continue


Tokens Iterator
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to extract data from text containing certain delimiters. Such as text in CSV format for example.

Source

Set text source, which is used to parse data from every iteration.

Split text by

Set delimiters to separate text

Match Case

Enables case-sensitive search of the string beginning.

Skip first result

Ignore first extracted token

Skip last result

Ignore last extracted token

Use Regular Expressions

Enables regular expressions usage for search of the string beginning.

Include Defined Text into Result

Enables addition of defined text to the beginning of the string parsed.

Continue Until

Set condition for end of iteration. The following operation modes are possible:

End of Text - The iteration ends when a end of text is reached.

Result variable is empty - The iteration ends when token placed to Result variable is empty.

Iteration variable greater than - The iteration ends when the number of cycles exceeds the specified value.

In Result

Trim whitespaces

Remove white space characters (space, tab) from the beginning and end of extracted token.

Trim new line characters

Remove new line characters (Carrage Return and Line Feed) from the beginning and end of extracted token.

Ignore empty results. continue next iteration

Perceive empty token as a significant.

Result Variable

Set name of the variable data to be parsed in.

Iteration Variable

Set variable name iteration number to be placed in.

See also

Iterators

Iterator Break

Iterator Continue


Iterator Continue
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to pass over the current iteration to the next iteration during iterator execution. In other cases it is ignored.

See also

Iterators


Iterator Break
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to finish the current iterator execution. In other cases is ignored.

See Also

Iterators


Modifiers
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Modifiers are processing components, used to modify text sources and message parts.

Modifiers are placed in the Modifiers folder in Components Palette.

There are the following modifiers in AEP

Component | Description
Attachments Modifier | Used to add or remove attachments in messages.
Block Modifier | Used for block modification of the text source.
HTML Modifier | Used for modification of a HTML source
Line Modifier | Used for line modification of the text source.
Message Parts Modifier | Used for modification of message parts.
Regular Expression Modifier | Used for modification of text sources using regular expressions.
Simple Modifier | Used for modification of text sources with using simple deletion and converting actions.
Text Modifier | Used for modification of a text source.

Remarks

Modifiers are powerful components allowing modification of messages on the fly but only if Realtime Processing is enabled for their rules.


Attachments Modifier
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to add or remove attachments in messages.

Action

Set an action to be carried out with attachment. The following actions are possible:

Delete All Attachments - Delete all attachments from message.

Delete Custom Attachments - Delete all attachments using custom mask.

Add File Attachment - Add attachments into message using specified in the component file list.

Add Text Attachment - Add text attachment into message using specified in the component text.

Custom Mask

Set a mask which is used to select attachments.

Except

This check box invert condition (not allow files with mask)

Text Attachment

Set a text which is used for addition of text attachment.

Attachment Name

Set a name of text attachment. If this flag is enabled, the unique name will be generated and used.

Default Codepage

Set the character set standard will be used for default encoding.

Setup File Attachments

Set a file list which will be added into message as attachments.

Encode Attachment

Set bit and binary formats for encoding the message part.

Allow 8-bit Characters in Headers

Specify whether foreign character sets, high ASCII, or double-byte character sets (DBCS) are allowed in the header without encoding. If this check box is cleared, these characters will be encoded.

See also

Message Parts Modifier

Modifiers


Block Modifier
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used for block modification of a text source. It is possible to delete, insert and modify blocks defined by the user condition.

Source

Set text source blocks to be modified into.

Start After

Set condition for beginning of the block to be modified. The following operation modes are possible:

Begin of Data - The block starts at the beginning of the data source.

After Defined Text - The block starts after the specified text.

Match Case

Enables case-sensitive search for the block beginning.

Line Start Only

Enables checking that the block beginning found is at the beginning of a line.

Whole Text

Enables comparison mode in which defined text must completely coincide with the beginning of the block.

Use Regular Expressions

Enables search for the block beginning using regular expressions.

Include Defined Text into Result

Enables addition of defined text to the beginning of the block modified.

Block Continue Until

Set block end condition. The following operation modes are possible:

End of Data - The block ends at the end of a text source.

Defined Text - The block ends before the text specified.

Defined Text or End of Source - The block ends before the text specified. If this text not found the block ends at the end of source.

Match Case

Enables case-sensitive search for the block end.

Line Start Only

Enables checking that the block beginning found is at the beginning of a line.

Whole Text

Enables comparison mode in which defined text must completely coincide with the end of the block.

Include Defined Text into Result

Enables addition of defined text to the end of the block modified.

Use Regular Expressions

Enables search for the block end using regular expressions.

New Block Action

Set up the action, made with retrieved block. The following actions are possible:

Delete String - deletion of the retrieved block.

Insert Text Before String - insertion of the given text in front of the retrieved block. Template usage is possible.

Replace String - Replacement of the retrieved block with the given text. Template usage is possible.

Insert Text After String - insertion of the given text after the retrieved block. Template usage is possible.

Process All Blocks

Enables modification of the all retrieved blocks, otherwise only the first block will be modified.

See also

Line Modifier

Modifiers


HTML Modifier
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used for modification of an HTML source. Delete, replace, modify HTML tags, or convert HTML to plain text.

Source

Set the text source data to be modified into.

Generate text from HTML

Convert HTML to plain text.

Strip HTML tags

Remove HTML tags. The following operation modes are possible:

All - Remove all HTML tags

User defined only - Remove only user-specified tags

All except user defined - Remove all tags, except user-specified

Remove SCRIPT tags

Remove tag SCRIPT. The <script> tag is used to define a client-side script, such as a JavaScript.

Remove STYLE tags

Remove tag STYLE. The <style> tag is used to define style information for an HTML document.

Remove COMMENT tags

Remove comment tag. The comment tag is used to insert comments in the source code. Comments are not displayed in the browsers.

Replace <BR> with carriage return

Replace tag <BR> to Carriage Return symbol.

Decode HTML Entities

Convert HTML Entities to symbols. For example: &copy; converted to © symbol.

See also

HTML

HTML Entity


Line Modifier
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used for line modification of a text source. Deletion of, insertion and modification of the lines defined on a condition given by the user is possible.

Source

Set the text source data to be modified into.

New String Start After

Set condition for begin of the line to be modified. The following operation modes are possible:

Begin of Line - The search string starts at begin of a line.

Defined Text - The search string starts after the specified text in a line. Template usage is possible.

Defined Text at Begin of Line - The search string starts after the specified text at begin of a line. Template usage is possible.

Match Case

Enables case-sensitive search of the string beginning.

Use Regular Expressions

Enables regular expressions usage for search of the string beginning.

Include Defined Text into Result

Enables addition of defined text to the beginning of the string modified.

Ignore Spaces

Enables space deletion at the beginning of the string modified.

New String Continue Until

Set condition for end of the line to be modified. The following operation modes are possible:

End of Line - The search string ends at the end of a line.

Defined Text - The search string ends before the specified text in a line. Template usage is possible.

Defined Text at End of Line - The search string ends before the specified text at the end of a line. Template usage is possible.

Defined Text or End of Line - The search string ends before the specified text or at the end of a line. Template usage is possible.

Match Case

Enables case-sensitive search of the string end.

Use Regular Expressions

Enables regular expressions usage for search of the string end.

Include Defined Text into Result

Enables addition of defined text to the end of the string modified.

Ignore Spaces

Enables space deletion at the end of the string modified.

New String Action

Set up the action, made with retrieved string. The following actions are possible:

Delete String - deletion of the retrieved string.

Insert Text Before String - insertion of the given text in front of the retrieved string. Template usage is possible.

Replace String - Replacement of the retrieved string with the given text. Template usage is possible.

Insert Text After String - insertion of the given text after the retrieved string. Template usage is possible.

In Result

Process All Strings

Enables modification of the all retrieved strings, otherwise only the first string will be modified.

Ignore Empty Strings

Enables skipping of empty strings.

See also

Block Modifier

Modifiers


Message Parts Modifier
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to modify parts of a message. Addition of a new part, replacement of a part by specified text and deletion of specified parts from the message are possible.

Action

Set an action to be made with message parts. The following actions are possible:

Add New Message Part - Adding a new part into the message. Part's type is set by Content Type, part's text by Part Body.

Replace Message Part - Replacement of message part, which type is specified by Content Type, by text from Part Body.

Delete Message Part - Deletion of message part, which type is specified by Content Type.

Keep Message Part - Deletion of all message parts, except type set by Content Type.

Content Type

Set type of part for the specified action.

Search depth

How deep the component will try to look for the desired part of the nested parts

Part Body

Set text of the part to be added or replaced.

Text as Message Part

Edit box contains the finished MIME Part

Allow 8-bit Characters in Headers

Specify whether foreign character sets, high ASCII, or double-byte character sets (DBCS) are allowed in the header without encoding. If this check box is cleared, these characters will be encoded.

Encode Text Using

Set bit and binary formats for encoding the message part.

Default Codepage

Set the character set standard will be used for default encoding.

See also

Attachments Modifier

Modifiers


Regular Expression Modifier
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used for modification of a text source using regular expressions. Deletion, insertion and replacement of the data defined on regular expression given by the user are possible.

Source

Set text source, which is used to modify data.

Method

Comparing methods. Match return True if the whole string matches the given pattern. Search tries to find a substring that matches the pattern.

Expression

Set regular expression.

Text Action

Set up action, made with retrieved data. The following actions are possible:

Delete Results - deletion of the retrieved data.

Insert Text Before Results - insertion of the given text in front of the retrieved data.

Replace Results - Replacement of the retrieved block with the given text.

Insert Text After Results - insertion of the given text after the retrieved block.

New Text Strings

Set up the texts, used while action is executed.

Process All Matches

Enables modification of the all retrieved data, otherwise only the first data, satisfying regular expression will be modified.

See also

Regular Expressions Flags

Modifiers


Simple Modifier
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to modify a text source with simple operations. It fulfills deletion of spaces and empty lines, changing register of characters.

Source

Set a text source to be modified.

Modifier Actions

Enables actions which will be to the text source. The following actions are possible:

Remove Left Spaces

Deletion of spaces from the begin of the text source.

Remove Right Spaces

Deletion of spaces from the end of the source.

Remove Duplicate Spaces

Replacement of repeated spaces by one space.

Remove All Empty Lines

Delete all empty lines in the source.

Remove Leading Empty Lines

Delete all empty lines in the beginning of the source.

Remove Two or More Empty Lines

Delete all lines except the first one in a block of empty lines.

Remove Trailing Empty Lines

Delete all empty lines in the end of the source.

Remove New Line Characters

Delete all new line characters in the source.

Convert to Lowercase

Converting all letters from the text source to lowercase.

Convert to Uppercase

Converting all letters from the text source to uppercase.

Capitalize Words

Capitalizing first letter of all words from the text source.

See also

Modifiers


Text Modifier
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used for modification of a text source. Deletion and modification of the source defined on a condition given by the user is possible.

Source

Set the text source data to be modified into.

Search in text

Set search data to be modified. The following operation modes are possible:

String - Search data is a string.

Characters - Search data is a group of characters. Each of characters will be used as data to find.

Match Case

Enables case-sensitive search of the string or characters.

Use Regular Expressions

Enables regular expressions usage for search of the string.

Use Wildcards

Enables wildcards usage for search of the string.

Begin from

Set condition for beginning of the text to be modified. The following operation modes are possible:

Begin of Source - The block starts at the beginning of the data source.

After Defined Text - The block starts after the specified text.

Match Case

Enables case-sensitive search for the text beginning.

Line Start Only

Enables checking that the text beginning found is at the beginning of a line.

Use Regular Expressions

Enables search for the text beginning using regular expressions.

Include Defined Text

Enables addition of defined text to the beginning of the block modified.

Continue Until

Set text end condition. The following operation modes are possible:

End of Source - The block ends at the end of a text source.

Defined Text - The block ends before the text specified.

Defined Text or End of Source - The block ends before the text specified. If this text not found the block ends at the end of source.

Match Case

Enables case-sensitive search for the text end.

Line Start Only

Enables checking that the text beginning found is at the beginning of a line.

Include Defined Text into Result

Enables addition of defined text to the end of the text modified.

Use Regular Expressions

Enables search for the text end using regular expressions.

Action

Set up the action, made with retrieved string. The following actions are possible:

Remove - deletion of the retrieved string.

Replace - Replacement of the retrieved string with the given text. Template usage is possible.

Process All Text Blocks

Enables modification of the all retrieved strings, otherwise only the first string will be modified.

See also

Block Modifier

Modifiers


Regular Expresion Flags
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Email Parser uses popular Boost Library for operating with regular expressions (RegExp). Regular Expressions use Perl syntax, but not support modifiers in expression only via Regexp Flags

You can find more information about Regular Expressions Syntax on this pages: PerlRe, PCRE

Method

Comparing methods. Match succeeded if the whole string matches the given pattern. Search succeeds if a substring that matches the pattern founded in string.

Result not Begin of Line

When this flag is set then result does not represent the start of a new line.

Result not End of Line

When this flag is set then result does not represent the end of a line.

Result not Begin of Word

When this flag is set then result can never match the start of a word.

Result not End of Word

When this flag is set then result can never match the end of a word.

Dot not Match Newline

Specifies that the expression "." does not match a newline character. This is the inverse of Perl's /s modifier.

Dot not Match Null

Specifies that the expression "." does not match a character null '\0'.

Match Any Results

Specifies that if more than one match is possible then any match is an acceptable result: this will still find the leftmost match, but may not find the "best" match at that position. Use this flag if you care about the speed of matching, but don't care what was matched (only whether there is one or not).

Match Partial Results

Specifies that if no match can be found, then it is acceptable to return a match [from, last) such that from!= last, if there could exist some longer sequence of characters [from,to) of which [from,last) is a prefix, and which would result in a full match. This flag is used when matching incomplete or very long texts.

Match Single Line

Equivalent to the inverse of Perl's /m modifier; prevents ^ from matching after an embedded newline character (so that it only matches at the start of the text being matched), and $ from matching before an embedded newline (so that it only matches at the end of the text being matched).

Ignore Case

Disable case-sensitive search

Use Locale Specific Collation

Uses the default system locale for string comparison.


Caching in components working with data servers
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Processing components that work with data servers allow caching when connected to a server. Caching reduces message processing time by a rule list. This is ensured by the fact that connection to a data server is established only once and maintained for as long as is necessary.

AEP uses caching in the following components:

·Database Access

·Simple Database Access

·Database Iterator

·Excel Access

·Excel Iterator

Caching can be used:

·for single message processing by a rule list

·for the whole session, i.e. as long as all messages received in one account check are being processed

Enable Caching

Use caching

Enable Session Cache

Use caching for whole session

Remarks

Besides making the processing faster, caching allows using special features of some databases. For example, when adding a line into MySQL table, identifier of the entry added can be parsed using the LAST_INSERT_ID function.

INSERT INTO CLIENT (id,email)

VALUES(NULL,'<%Sender%>); # generate ID by inserting NULL

INSERT INTO ORDER (client,orderno)

VALUES(LAST_INSERT_ID(),'<%OrderNo%>'); # use ID in second table

Database Access component allows executing only one SQL expression. So, two components are needed to perform the instructions. Without caching, LAST_INSERT_ID() will always return 0 in the second instruction. This happens because connection is terminated once the component with the first instruction is executed, and the value LAST_INSERT_ID is lost. Caching offers a solution for this problem.


Variables
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

All the processing components use variables for data exchange

Variable list

Separate variable list is kept for each rule. This list can be accessed through context menu of the fields where the variables are usable. To enter variable name in a field, you can just choose it from the list. This allows to avoid mistakes possible when variable names are entered via a keyboard. Besides, the name syntax is automatically adjusted to the context. For example, the variable "Variable" will be entered into a text field as <%Variable%>, in database component as '<%Variable%>', and in JScript and VBScript components as Variable.Value (name of the method .Value is a case sensitive)

Variable grouping

For greater usage convenience, the variable list is organized as a hierarchic menu system. It may contain:

·individual variables

·the group "Variables"

·user-created groups

Some variables may not be included in any group. They are placed at the top of the list, so they can be accessed by a single mouse click. Most frequently used variables are normally placed so.

The group "Variables" is created automatically. By default, all variables are placed into that group.

User groups are created to provide for more convenient organization of the list. Each group is also a list, which may contain subgroups and individual variables. This system allows to optimize the number of menu items with great number of variables, as well as to sort variables by categories, e.g., "Shipment Details" or "Client Parameters".

Keeping a List

VarGroup - There is the list editor button in the fields where variables are to be set. In the list editor, you can set the variable position in the list, as well as create new groups. The group in which the variable is contained is marked with a marker in the menu.

To set the variable position in a list, choose the desired group and click <Place Here>.

To create a new group, click <Add New Group> in the desired place of the list and enter the group name. The current variable will be automatically moved into that group.

A group exists in a list until it contains at least one variable. If all variables in a group have been deleted, the group is automatically deleted as well.

Using Environment variable inside variable template

Environment variable substitution can be used inside a variable template. <%test%> it's a variable template that will be replaced by the value of variable 'test'. <%%TEMP%%> it's an environment variable template. The template will be replaced by value with the 'TEMP' environment variable.


Examples Description
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The following examples will help you to study AEP features

Example | Description
Maillist | Creating a maillist from DigiBuy order forms.
Example of Block Parsers Usage | Processing of RegNow order forms.
Example of SMTP Sender Usage | Sending lost registration code automatically.
Example of database usage | Incoming messages statistic.
Example of ActiveX object usage | Compiling a maillist and saving it in an Excel document.
Example of Line Iterator usage | Trade parts table parsing.
Example of Block Iterator usage | Trade parts table parsing with multiline descriptions.
Example of Word Iterator usage | Count of message words.
Example of work with a database using Simple Database Access | Incoming messages statistic.


Creating a maillist from DigiBuy order forms
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Creating a maillist from DigiBuy order forms - is the simplest example of AEP usage.

Example Description

This example shows how Line Parser and File Writer work.

To load the example, import the rules list rules.txt from the Examples\Simple folder.

The example explains how to create a maillist from DigiBuy order forms. When a message is received, the sender name and e-mail address are saved to the file userlist.txt in the Examples\Simple folder.

Example Rule Description

Filtering

The rule contains Subject Filter, which filters the messages except debug messages from the example.

Processing

·The sender name and address are parsed from Customer Name and Email Address fields

·The data parsed are saved to file

Debug Messages

Contains debug message for the rule operation debugging.


RegNow order forms processing
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

RegNow order forms processing - an example of Block Parsers usage.

Example Description

This example shows how to parse data from messages containing the same fields using the block parser.

To load the example, import the rules list rules.txt from Examples\BlockParser folder.

The example is the solution of task of parsing data from RegNow order forms. Upon message receiving, customer's name, company name, mailing address and country code are parsed from it. Based on the country code, the country name is identified. The data parsed are stored into a text file.

Example Rule Description

Filtering

There is the Subject Filter that will filter all messages except debug messages from the example.

Processing

·Parsing of Shipping block and Purchasing block

·Identifying which of the blocks is to be processed

·Processing of the shipping block if necessary

·Processing of the purchasing block if necessary

·Identification of the country name based on the country code

·Storage of the data parsed into a file

Debug Messages

There are two debug messages to show how the rule works. The first one contains filled purchasing block; the second one contains filled shipping block..


SMTP Sender usage example
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Automatic Sending of the Lost Registration Code - SMTP Sender Usage Example.

Example Description

This example shows how the SMTP Sender processor works.

To load the example, import the rules list rules.txt from the Examples\SMTP folder.

The example is solution of the task of automation of lost registration code sending. Upon receiving of a message with the words "lost" and "code" in its subject, a message with registration code is automatically sent to a registered user.

The text file users.txt in the Examples\SMTP folder is used as the database of users and their codes.

Example Rule Description

Filtering

There are filters used to find out if a message is lost code request.

Processing

·Parsing of the sender's e-mail address

·Search for code of sender with that address

·If such a sender is found, a message with lost code is sent to him

Debug Messages

There are two debug messages. The first one is from registered user listed in the users database, the second one is from unregistered user.


An Example of Work with Database
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Incoming message Statistics - An Example of Work with Database.

Example Description

This example shows how the Database Access processor, used to exchange data with databases, works. This component allows specification of the data source, SQL instruction template, and names of variables data to be sent to.

To load the example, load the rules list rules.txt from the Examples\Database folder.

The example is the solution of the task of maintaining incoming messages statistics. When a message is received, sender's name and e-mail address are stored in the database. For each sender, the total number of received messages, dates of receiving the first and the last message are also stored.

The STATISTIC table from Microsoft Access database stats.mdb located in the Examples\Database folder is used as data source.

The following SQL instructions are used in the example - SELECT, INSERT .. INTO, UPDATE.

Example Rule Description

Filtering

There is the Subject Filter that filters all messages except debug messages from the example.

Processing

·Parsing of the sender's name and address.

·Search for sender with that name and address in the database.

·If no sender is found, the new entry containing the sender name and address and current date is created, incoming messages number is set to 1.

·If the sender is found, the last message date is refreshed, and incoming messages number is increased by 1.

Debug Messages

There is one debug message used to show how the rule works.


Creating a maillist and saving it in an Excel document
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Creating a maillist and saving it in an Excel document - ActiveX object usage example.

Example Description

This example shows how ActiveX objects can be used for message processing. To toggle on ActiveX objects, script components are used.

To load the example, import the rules list rules.txt from the Examples\ActiveX folder.

The example is the solution of maillist creating task. When a message is received, the sender's name and address are stored in the Excel list.xls document located in the Examples\ActiveX folder.

Example Rule Description

Filtering

There is the Subject Filter that filters all messages except debug messages from the example.

Processing

·Parsing of the sender's name and address.

·Saving the data parsed in an Excel document using JScript source code.

Debug Messages

There is a debug message used to show how the rule works.

Remarks

This example will work only if MS Excel is installed on your computer.


An Example of Word Iterator Usage
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Count of message words - An Example of Word Iterator Usage.

Example Description

This example shows how to use Word Iterator component, which allows to parse data word by word and to execute a set of processing components for every parsed word.

To load the example, import the rules list rules.txt from Examples\WordIterator folder.

The example allows counting of the number of words in a message and to store words into a text file.

Example Rule Description

Filtering

There is the Subject Filter that filters all messages except debug messages from the example.

Processing

·Iterating through Body text source, parsing every word to the Word variable and executing for it next operations:

·Storing of the word parsed and its number into the text file.

Debug Messages

There is one debug message used to show how the rule works.


An Example of Line Iterator Usage
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Trade Parts table parsing - An Example of Line Iterator Usage.

Example Description

This example shows how to use Line Iterator component, which allows to parse data line by line and to execute a set of processing components for every parsed line.

To load the example, import the rules list rules.txt from Examples\LineIterator folder.

This example is solution of the task of parsing data from orders, which are represented in table form. Upon receipt of a message, a block with table is parsed from it. Using Line Iterator component rows of the table are parsed from the block. Fields values are parsed from them using Regular Expression Parser. The values are stored into a text file in user format.

Example Rule Description

Filtering

There is the Subject Filter that filters all messages except debug messages from the example.

Processing

·Parsing of parts table to the PartsBlock variable.

·Iterating through PartsBlock, parsing every line to the Part variable and executing for it next operations:

·Parsing of part fields from Part to PartName, PartMan, PartDc, PartCount variables.

·Storing of the data parsed into the text file.

Debug Messages

There is one debug message used to show how the rule works.


An Example of Block Iterator Usage
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Parsing of Trade Parts table with Multiline Descriptions - An Example of Block Iterator Usage.

Example Description

This example shows how to use Block Iterator component, which allows to parse data block by block and to execute a set of processing components for every parsed block.

To load the example, import the rules list rules.txt from Examples\BlockIterator folder.

The example is solution of the task of parsing data from orders, which are represented in tables by multiple rows. Upon receiving of a message, a table block is parsed from it. Using Block Iterator multiline parts descriptions are parsed from the block for parts of one kind. These blocks are split to rows using Line Iterator Component. Using Regular Expression Parser description field's values are parsed from rows. The values are stored into a text file in user format.

Example Rule Description

Filtering

There is the Subject Filter that filters all messages except debug messages from the example.

Processing

·Parsing of parts table to the PartsData variable.

·Iterating through PartsData, parsing every block to the PartBlock variable and executing for it next operations:

·Iterating through PartBlock, parsing every line to the Part variable and executing for it next operations:

§Skipping iteration if Part contains found mark.

§Parsing of part fields from Part to PartName, PartCount variables.

§Storing of the data parsed into the text file.

Debug Messages

There is one debug message used to show how the rule works.


An Example of Modifiers Usage
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Testing for potential fraud orders - An Example of Modifiers Usage.

Example Description

This example shows how to use Modifiers. These components allows you to modify a message, it's parts and text sources in different ways. In this example Block Modifier and Line Modifier are used.

To load this example, import the rules list rules.txt from Examples\Modifiers folder.

This example is a solution of a task of purchaser data checking which are parsed from RegNow Orders. The IP and e-mail of purchaser are parsed and checked. If IP is over proxy-server or e-mail is free then message priority will be changed to high. The checking's are made with help of online services for which queries will be done with help of HTTP Reader component.

On receiving RegNow order, IP and e-mail are parsed from it. Parsed data are checked with online services using HTTP Reader component, the replies from online services are stored in AnswerIP and AnswerEmail variables and are checked by following two conditions. The result will be inserted into the message body with Block Modifier. If IP is proxy-based or e-mail is free then message priority will be changed to high using Line Modifier.

Rule Example Description

Filtering

There is the Sender Name Filter that filters all messages except debug messages from the example.

Processing

·IP and e-mail extraction into IP and Email variables.

·Data checking by online services using HTTP Reader component.

·Checking results of HTTP queries and saving them in IPCheck and EmailCheck variables.

·Inserting IPCheck and EmailCheck into the begin of Body with Block Modifier component.

·Checking if high priority have to be set.

·Setting of the message priority to high with Line Modifier component.

Debug Messages

To check rule use messages from example folder. You can check the rule with these messages using RFC822 Account.


Incoming message statistics
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Incoming message statistics - an example of work with a database using Simple Database Access.

Example Description

This example shows how the processor Simple Database Access, used to exchange data with a table in defined database, works. This component allows definition of the data source, the table, the list of correspondence between fields of the table defined and the variables used to exchange data.

To load the example, import the rule list rules.txt from the Examples\Simple Database folder.

The example shows the way of solving the problem of keeping incoming message statistics. When a message is received, sender's name and address is stored in the STATISTICS table. Besides, the number of messages received, the first and the last message receipt dates are stored for each sender.

Microsoft Access database stats.mdb located in the Examples\Database folder is used as data source in this example.

Example Rule Description

Filtering

The example contains Subject Filter, which filters all the messages other then example debug messages.

Processing

·Parsing and conversion of the message date with the Date Parser.

·Parsing of the sender's name and address.

·Adding an entry for a new sender or updating for registered sender is done by the same component Simple Database Access.

Debug Message

The example contains debug messages to show how the rule works.

Remarks

Compare the rule in this example with the rule in the example Incoming message statistics. Please note that now only one component is used, which makes the rule much simpler.


Rules Debugging
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

A rules list is used for message processing. When a rule is compiled, it is often necessary to check if it works properly.

AEP contains the following tools to make debugging easier:

·Debug messages. With debug messages you can check whether a rule works properly without connecting to a mail server.

·Step-by-Step Debugging. Debugger allows you control of rule execution with debug message on every component.

·Immediate Variables panel. Allows you to watch values of Variables on every step of debug process.

·Breakpoints. Allow to pause debug execution on selected component during processing debug message. Useful if you don't use step-by-step debugging and your rule contains many components or complex branching.

·Debug Alert actor. The Debug Alert actor allows display of variable values in the messages box or writing them in the Log.

Debug Messages are used to make sure that a Rule works properly. Debug messages are not downloaded from mail servers, therefore their processing takes less time than processing of incoming messages does. Except that, there is no difference between debug messages and incoming messages. Debug Messages are stored in the Debug Messages Panel. AEP allows processing the one or more debug messages either with the rule or with all the rules from the list. These commands are available from context menu of the debug message.

There are two methods of debug message creating:

1.Loading from a file. AEP can load messages in RFC 2822 standard and binary form of MAPI messages saved by MS Outlook

2.Capture incoming message. This method is more accurate, because the message is stored as is. In contrast to the conversion of the MAPI Messages generated by MS Outlook

You can view debug message with Message Analyzer tool.

See also

Debug Alert

Capture Incoming Messages

Log Viewer


Capture Incoming Message
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

AEP allows creation of debug messages by capture incoming messages.

There are the following capture modes

Icon | Description
iconcatch | Capture of the first message from incoming messages list.
iconcatchall | Capture all messages from incoming messages list.

Message capture terminates automatically when required number of messages is caught.

The messages are added into the Debug Messages Panel with group name same as Rule name. If a message doesn't fit any rule, it is added to Imported group.

See also

Rules Debugging

Log Window


Information for Programmers
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

AEP provides a set of processing components that allows management of most ordinary data parsing, modification and storage tasks. If capacities of the set are insufficient for some reason, it is possible to process data using more general tools.

In AEP, such tools are the following:

·Script components

·ActiveX objects

·External programs

·Dynamic loaded libraries

Script Components

Script components contain a source code in a scripting language to be executed during message processing. AEP provides components for the following scripting languages: JScript and VBScript.

Use of scripting components allows expansion of processing capabilities considerably. For example, in a script component it is possible to perform calculations, to work with ActiveX objects, to use arrays.

A script component can access any variables contained in a rule. In scripting languages, a variable takes a form of an Object type object. Object name is the same as variable name. To access value of a variable, .Value property of the object is used.

Besides variables, it is also possible to use the following objects

Variable | Description
message | Allows extraction of data from message being processed
debug | Allows recording of events in the Log

ActiveX objects

Script components make it possible to use ActiveX objects. For more information look here.

External programs

It's possible to exchange data with external programs using Run Executable component. For more information look here.

Dynamic loaded libraries

It's possible to call DLL functions using Run Dynamic Library component. For more information look here.

See also

More about Scripting Components


Usage of ActiveX objects in Script Components
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Script components allow to use ActiveX objects into the AEP greatly expanding data processing and storing capabilities.

Below is the example of saving the processing data in a Microsoft Excel document using JScript.

Global Variables

SenderName

SenderEmail

JScript Code

var wbname = "C:\\Program Files\\Advanced Email Parser\\Examples\\ActiveX\\list.xls";

var wbkey = SenderEmail.Value;

var wbdata = SenderName.Value;

var xl = new ActiveXObject("Excel.Application");

var wb = xl.Workbooks.Open(wbname);

var ws = wb.Worksheets(1);

var item = ws.Columns(1).Find(wbkey);

if(item)

{

item.Cells(1, 2) = wbdata;

}

else

{

var cnt = ws.Rows.Count;

var idx = 1;

while(idx < cnt)

{

if(ws.Cells(idx, 1).Value == null) break;

idx++;

}

ws.Cells(idx, 1) = wbkey;

ws.Cells(idx, 2) = wbdata;

}

wb.Close(true);

See also

Information for Programmers

Script Components


The Message Object
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Opens access to the message currently under processing.

Subject property

HRESULT get_Subject(BSTR *pVal);

HRESULT put_Subject(BSTR newVal);

Getting or modifying a Message Subject.

pVal

Pointer to BSTR the Message Subject to be placed in.

newVal

BSTR that contains new Message Subject.

SenderName property

HRESULT get_SenderName(BSTR *pVal);

HRESULT put_SenderName(BSTR newVal);

Getting or modifying the message Sender Name.

pVal

Pointer to BSTR the Sender Name to be placed in.

newVal

BSTR that contains new Sender Name.

SenderEmail property

HRESULT get_SenderEmail(BSTR *pVal);

HRESULT put_SenderEmail(BSTR newVal);

Getting or modifying the message Sender Email.

pVal

Pointer to BSTR the Sender Email to be placed in.

newVal

BSTR that contains new Sender Email.

RecipientName property

HRESULT get_RecipientName(BSTR *pVal);

HRESULT put_RecipientName(BSTR newVal);

Getting or modifying the message Recipient Name.

pVal

Pointer to BSTR the Recipient Name to be placed in.

newVal

BSTR that contains new Recipient Name.

RecipientEmail property

HRESULT get_RecipientEmail(BSTR *pVal);

HRESULT put_RecipientEmail(BSTR newVal);

Getting or modifying the message Recipient Email.

pVal

Pointer to BSTR the Recipient Email to be placed in.

newVal

BSTR that contains new Recipient Email.

Text property

HRESULT get_Text(BSTR *pVal);

HRESULT put_Text(BSTR newVal);

Getting or modifying the message Body.

pVal

Pointer to BSTR the message Body to be placed in.

newVal

BSTR that contains new message Body.

Size property

HRESULT get_Size(long *lVal);

Getting the message Size.

lVal

Pointer to long the message size to be placed in.

Account property

HRESULT get_Account(BSTR *pVal);

HRESULT put_Account(BSTR newVal);

Getting or modifying the message Account.

pVal

Pointer to BSTR the Account to be placed in.

newVal

BSTR that contains new Account.

Header property

HRESULT get_Header(BSTR bstrHeader, BSTR *pVal);

Getting the message header.

bstrHeader

BSTR that specifies what header is required.

pVal

Pointer to BSTR the specified header value to be placed in.


Debug Object
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Used to debug blocks and write lines into the Log.

HRESULT WriteDebugLog( BSTR bstrData, long nFlags );

bstrData

Line to be written into the Log. It is possible to write several lines divided by the line feed symbol (\n) at once.

nFlags

Status flag. May take the following values:

0x00000000 EMSLOGGER_INFO

Means that the operation succeeded. In the Log, it is displayed as iconinfo

0x00000001 EMSLOGGER_WARNING

Means that the operation was executed with a remark. In the Log, it is displayed as iconwarning

0x00000002 EMSLOGGER_ERROR

Means that an error occurred while executing the operation. In the Log, it is displayed as iconerror


Glossary
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Filtering

The process of checking whether message processing is necessary or not.

Filter

A rule component used for filtering.

Processing

The process of parsing, changing, and storing data from messages.

Processing queue

The list of messages to be processed.

Rule list

The set of rules used for filtering and processing of incoming messages.

Rule

A set of rule components that binds filtering settings and message processing method into integral whole.

Rule component

A component part of a rule. A filter, a processing component, or a debug message.

Processing component

A rule component that determines data processing method.

Processor

A processing component that determines data changing and storing method.

Parser

A processing component that determines the method of data parsing from text sources into variables.

Actor

A processing component that doesn't change any variables.

External component

A processing component that allows data processing with other applications.

Script component

A processing component that allows data processing with a program written in scripting language.

Condition

A processing component that allows data processing with certain set of processing components depending on value of certain variable.

Iterator

A processing component that allows to execute certain set of processing components for lines, blocks, words and regular expressions in the specified text source.

Modifier

A processing component that allows to modify (adding, deleting, converting) specified text source or message parts.

Text source

Full message, all message headers, a message header, a message body (raw, text or HTML), or a variable.

Broker mode

The mode of working with an account where AEP is a broker between a mail client and a mail server.

Collector mode

The mode of working with an account where messages loading from a mail server is scheduled.

Debug message

A message used to check whether a rule works properly or not.

Capture

The function of capture incoming messages and copying them into debug messages


Registration
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can register your copy of AEP via the registration service using any major credit card. You can register on-line, using fax, toll-free phone, by check or wire transfer. Money orders are also accepted.

On the Internet, go to our Web page at Purchase page

If you don't have convenient Web access, the next best way to order AEP is by fax (also using the credit card) or phone (toll-free).

Be sure to give us the correct e-mail address when filling the order form; if you make a mistake when typing it, we'll be unable to send you your registration code.

You can also use wire transfer to register AEP. Please contact us in technical support area.

When you register, you'll be given the Registration Key (Serial Number).

Your registration key will work for all minor versions of Advanced Email Parser (or we may provide you with a new key, if the keys will be changed for some reason).


Unregistered copy limitations
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The unregistered version of Advanced Email Parser is fully functional and works without restrictions for 30 days. Also, we can provide only limited support (and with low priority) to unregistered users.

When you register, you'll get the registration key (serial number) which removes the registration screen. Your registration key will work for all future versions of Advanced Email Parser (or we may provide you with the new key, if the keys will be changed for some reason).


Online support
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Our technical support service is always glad to help you and to answer any of your questions. Please, keep to the following rules when contacting the technical support service:

·If your question concerns incorrect operation of the software, do not forget to provide the version number of your operating system, service/upgrade pack, Microsoft Internet Explorer installed on your computer.

·Please, include any additional details you see appropriate so that the developers can reconstruct your exact situation in the lab.

·If you are a registered user, specify your serial number or order number. It will help us to process your inquiry faster.

·Check if a newer version is available on the official web-site, the problem might be already corrected in the newer version.

You can contact the technical support service via trouble ticket system at Tech Support Center. We also recommend you to visit our web-site where you can find additional information about our products.


Web server
No contents entries on this page
Go to previous topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

At the web-site you can find the complete list of our software products and the latest news, download trial versions of the products and register your software.

Most of our products are updated once a month on average. Don't forget to visit our site, we are always glad to see you! Should you have any questions or suggestions, please, contact the technical support service.